Improper privilege management in ax25-tools
Priority LOW 30CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
The AX.25 daemon (ax25d) in ax25-tools before 0.0.8-13 does not check the return value of a setuid call. The setuid call is responsible for dropping privileges but if the call fails the daemon would continue to run with root privileges which can allow possible privilege escalation.
Why it matters now
EPSS 0.00375 31st percentileScored 2026-11-07
Fix Fixed ax25-tools (ax25-tools): 0.0.8-13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ax25-tools | ax25-tools | before 0.0.8-13 | 0.0.8-13 | Patch available | CNA |
- ax25-tools Vendorax25-tools Affected before 0.0.8-13 Fixed in 0.0.8-13 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linux-ax25:ax25-tools:*:*:*:*:*:*:*:* | before 0.0.8-13 | Vulnerable | Linux-ax25 |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:linux-ax25:ax25-tools:*:*:*:*:*:*:*:* Versions before 0.0.8-13 Vulnerable ·Linux-ax25
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA ax25-tools (ax25-tools) Fixed in 0.0.8-13
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-2910
- 2026-10-03 Alias added: GHSA-mrq3-m48q-67j2
References
Sources
- CVE-2011-2910 · CVE Program
- CVE-2011-2910 · NVD
- FIRST EPSS
- GHSA-mrq3-m48q-67j2 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-2910 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences