Multiple cross-site scripting (XSS) vulnerabilities in phpPgAdmin before 5.0.3 allow…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in phpPgAdmin before 5.0.3 allow remote attackers to inject arbitrary web script or HTML via (1) a web page title, related to classes/Misc.php; or the (2) return_url or (3) return_desc parameter to display.php.
Why it matters now
EPSS 0.0253 85th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phppgadmin:phppgadmin:*:*:*:*:*:*:*:* | up to 5.0.2 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:2.2:*:*:*:*:*:*:* | 2.2 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.3:*:*:*:*:*:*:* | 3.3 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.4:*:*:*:*:*:*:* | 3.4 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.4.1:*:*:*:*:*:*:* | 3.4.1 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.5:*:*:*:*:*:*:* | 3.5 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:3.5.2:*:*:*:*:*:*:* | 3.5.2 | Vulnerable | Phppgadmin |
- cpe:2.3:a:phppgadmin:phppgadmin:*:*:*:*:*:*:*:* Versions up to 5.0.2 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:2.2:*:*:*:*:*:*:* Versions 2.2 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.4:*:*:*:*:*:*:* Versions 3.4 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.4.1:*:*:*:*:*:*:* Versions 3.4.1 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.5:*:*:*:*:*:*:* Versions 3.5 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:3.5.2:*:*:*:*:*:*:* Versions 3.5.2 Vulnerable ·Phppgadmin
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phppgadmin:phppgadmin:3.5.3:*:*:*:*:*:*:* | 3.5.3 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:4.2.1:*:*:*:*:*:*:* | 4.2.1 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:4.2.2:*:*:*:*:*:*:* | 4.2.2 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:4.2.3:*:*:*:*:*:*:* | 4.2.3 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Phppgadmin |
| cpe:2.3:a:phppgadmin:phppgadmin:5.0.1:*:*:*:*:*:*:* | 5.0.1 | Vulnerable | Phppgadmin |
- cpe:2.3:a:phppgadmin:phppgadmin:3.5.3:*:*:*:*:*:*:* Versions 3.5.3 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:4.2.2:*:*:*:*:*:*:* Versions 4.2.2 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:4.2.3:*:*:*:*:*:*:* Versions 4.2.3 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Phppgadmin
- cpe:2.3:a:phppgadmin:phppgadmin:5.0.1:*:*:*:*:*:*:* Versions 5.0.1 Vulnerable ·Phppgadmin
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-3598
- 2026-10-03 Alias added: GHSA-7rg3-7j2j-797w
References
Patch 5
- [phppgadmin-news] 20111003 [ppa-news] phpPgAdmin 5.0.3 released
- https://github.com/phppgadmin/phppgadmin/commit/1df248203de055f97e092b50b1dd9643ccb73842
- [oss-security] 20111004 Re: CVE Request -- phpPgAdmin -- Multiple XSS flaws fixed in v5.0.3
- [oss-security] 20111004 CVE Request -- phpPgAdmin -- Multiple XSS flaws fixed in v5.0.3
- https://bugzilla.redhat.com/show_bug.cgi?id=743205
More Phppgadmin vulnerabilities
- TI-2007-02772 Cross-site scripting (XSS) vulnerability in sqledit.php in phpPgAdmin 4.1.1 allows remote… CVSS 2.0HIGH 9.3
- TI-2001-00471 Directory traversal vulnerability in phpPgAdmin 2.2.1 and earlier versions allows remote… CVSS 2.0HIGH 7.5
- TI-2007-05501 Cross-site scripting (XSS) vulnerability in phpPgAdmin 3.5 to 4.1.1, and possibly 4.1.2… CVSS 2.0MEDIUM 4.3
- TI-2008-05303 Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and… CVSS 2.0MEDIUM 4.3
- TI-2005-02135 Encoded directory traversal vulnerability in phpPgAdmin 3.1 to 3.5.3 allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2011-3598 · CVE Program
- CVE-2011-3598 · NVD
- FIRST EPSS
- GHSA-7rg3-7j2j-797w · GitHub Advisory Database · CC BY 4.0
- CVE-2011-3598 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences