Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode…
Priority LOW 28CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.
Why it matters now
EPSS 0.00338 27th percentileScored 2026-11-07
Fix Partial puppet (RubyGems): 2.7.5, 2.6.11Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | puppet (RubyGems) | 2.7.0 to before 2.7.5 | 2.7.5 | Patch available | GHSA-mpmx-gm5v-q789 |
| — | puppet (RubyGems) | before 2.6.11 | 2.6.11 | Patch available | GHSA-mpmx-gm5v-q789 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- puppet (RubyGems) Vendor— Affected 2.7.0 to before 2.7.5 Fixed in 2.7.5 Patch available GHSA-mpmx-gm5v-q789
- puppet (RubyGems) Vendor— Affected before 2.6.11 Fixed in 2.6.11 Patch available GHSA-mpmx-gm5v-q789
CPE configurations NVD · 23
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.3:*:*:*:*:*:*:* | 2.6.3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.4:*:*:*:*:*:*:* | 2.6.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.5:*:*:*:*:*:*:* | 2.6.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.6:*:*:*:*:*:*:* | 2.6.6 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.7:*:*:*:*:*:*:* | 2.6.7 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.8:*:*:*:*:*:*:* | 2.6.8 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.6.9:*:*:*:*:*:*:* | 2.6.9 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.3:*:*:*:*:*:*:* Versions 2.6.3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.4:*:*:*:*:*:*:* Versions 2.6.4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.5:*:*:*:*:*:*:* Versions 2.6.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.6:*:*:*:*:*:*:* Versions 2.6.6 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.7:*:*:*:*:*:*:* Versions 2.6.7 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.8:*:*:*:*:*:*:* Versions 2.6.8 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.6.9:*:*:*:*:*:*:* Versions 2.6.9 Vulnerable ·Puppet
Show 13 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:2.6.10:*:*:*:*:*:*:* | 2.6.10 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Puppetlabs |
| cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Puppetlabs |
| cpe:2.3:a:puppet:puppet:0.25.0:*:*:*:*:*:*:* | 0.25.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.1:*:*:*:*:*:*:* | 0.25.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.2:*:*:*:*:*:*:* | 0.25.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.3:*:*:*:*:*:*:* | 0.25.3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.4:*:*:*:*:*:*:* | 0.25.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.5:*:*:*:*:*:*:* | 0.25.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:0.25.6:*:*:*:*:*:*:* | 0.25.6 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:2.6.10:*:*:*:*:*:*:* Versions 2.6.10 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Puppet
- cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Puppetlabs
- cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Puppetlabs
- cpe:2.3:a:puppet:puppet:0.25.0:*:*:*:*:*:*:* Versions 0.25.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.1:*:*:*:*:*:*:* Versions 0.25.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.2:*:*:*:*:*:*:* Versions 0.25.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.3:*:*:*:*:*:*:* Versions 0.25.3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.4:*:*:*:*:*:*:* Versions 0.25.4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.5:*:*:*:*:*:*:* Versions 0.25.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:0.25.6:*:*:*:*:*:*:* Versions 0.25.6 Vulnerable ·Puppet
Remediation
- Fix · GHSA-mpmx-gm5v-q789 puppet (RubyGems) Fixed in 2.7.5 Advisory →
- Fix · GHSA-mpmx-gm5v-q789 puppet (RubyGems) Fixed in 2.6.11 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise MRG 1 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2011-3871
- 2026-10-03 Alias added: GHSA-mpmx-gm5v-q789
References
Patch 4
Other 5
- https://puppet.com/security/cve/cve-2011-3871
- https://github.com/puppetlabs/puppet/commit/343c7bd381b63e042d437111718918f951d9b30d
- https://github.com/puppetlabs/puppet/commit/d76c30935460ded953792dfe49f72b8c5158e899
- https://github.com/puppetlabs/puppet
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2011-3871.yml
Sources
- CVE-2011-3871 · CVE Program
- CVE-2011-3871 · NVD
- FIRST EPSS
- GHSA-mpmx-gm5v-q789 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-3871 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences