The mod_pubsub module (mod_pubsub.erl) in ejabberd 2.1.8 and 3.0.0-alpha-3 allows remote…
Priority LOW 23CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The mod_pubsub module (mod_pubsub.erl) in ejabberd 2.1.8 and 3.0.0-alpha-3 allows remote authenticated users to cause a denial of service (infinite loop) via a stanza with a publish tag that lacks a node attribute.
Why it matters now
EPSS 0.02046 81st percentileScored 2026-11-07
Fix Fixed ejabberd (Hex): 2.1.9, 3.0.0-alpha-4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ejabberd (Hex) | before 2.1.9 | 2.1.9 | Patch available | GHSA-2h3q-v47h-f4rc |
| — | ejabberd (Hex) | 3.0.0-alpha-1 to before 3.0.0-alpha-4 | 3.0.0-alpha-4 | Patch available | GHSA-2h3q-v47h-f4rc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ejabberd (Hex) Vendor— Affected before 2.1.9 Fixed in 2.1.9 Patch available GHSA-2h3q-v47h-f4rc
- ejabberd (Hex) Vendor— Affected 3.0.0-alpha-1 to before 3.0.0-alpha-4 Fixed in 3.0.0-alpha-4 Patch available GHSA-2h3q-v47h-f4rc
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:process-one:ejabberd:2.1.8:*:*:*:*:*:*:* | 2.1.8 | Vulnerable | ProcessOne |
| cpe:2.3:a:process-one:ejabberd:3.0.0:alpha3:*:*:*:*:*:* | 3.0.0 alpha3 | Vulnerable | ProcessOne |
- cpe:2.3:a:process-one:ejabberd:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·ProcessOne
- cpe:2.3:a:process-one:ejabberd:3.0.0:alpha3:*:*:*:*:*:* Versions 3.0.0 alpha3 Vulnerable ·ProcessOne
Remediation
- Fix · GHSA-2h3q-v47h-f4rc ejabberd (Hex) Fixed in 2.1.9 Advisory →
- Fix · GHSA-2h3q-v47h-f4rc ejabberd (Hex) Fixed in 3.0.0-alpha-4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4320
- 2026-10-03 Alias added: GHSA-2h3q-v47h-f4rc
References
Other 7
- [oss-security] 20111119 CVE request: ejabberd before 2.1.9
- 77302
- [oss-security] 20111119 Re: CVE request: ejabberd before 2.1.9
- http://www.process-one.net/en/ejabberd/release_notes/release_note_ejabberd_2.1.9
- https://github.com/processone/ejabberd/commit/d3c4eab46f3cd54f7686cfed740d9c130b6801cf
- https://github.com/processone/ejabberd/commit/d5b4d6785879f0a5192c26f5b5e218aec8104798
- https://github.com/processone/ejabberd
More ProcessOne Ejabberd vulnerabilities
- TI-2007-00879 Unspecified vulnerability in the mod_roster_odbc module in ejabberd before 1.1.3 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2010-00292 ejabberd_c2s.erl in ejabberd before 2.1.3 allows remote attackers to cause a denial of… CVSS 2.0MEDIUM 5.0
- TI-2011-01532 expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before… CVSS 2.0MEDIUM 5.0
- TI-2014-07188 ejabberd before 2.1.13 does not enforce the starttls_required setting when compression is… CVSS 2.0MEDIUM 5.0
- TI-2013-05190 The TLS driver in ejabberd before 2.1.12 supports (1) SSLv2 and (2) weak SSL ciphers… CVSS 2.0MEDIUM 4.3
- TI-2009-00888 Cross-site scripting (XSS) vulnerability in ejabberd before 2.0.4 allows remote attackers… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2011-4320 · CVE Program
- CVE-2011-4320 · NVD
- FIRST EPSS
- GHSA-2h3q-v47h-f4rc · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4320 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences