code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow…
Priority LOW 37CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow remote attackers to execute arbitrary code via a crafted cookie in a user comment submission, which is not properly handled when it is deserialized.
Why it matters now
EPSS 0.03918 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed silverstripe/cms (Packagist): 2.4.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/cms (Packagist) | 2.4.0 to before 2.4.6 | 2.4.6 | Patch available | GHSA-gv6c-59h4-9pmg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/cms (Packagist) Vendor— Affected 2.4.0 to before 2.4.6 Fixed in 2.4.6 Patch available GHSA-gv6c-59h4-9pmg
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:2.4.3:*:*:*:*:*:*:* | 2.4.3 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:2.4.4:*:*:*:*:*:*:* | 2.4.4 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:2.4.5:*:*:*:*:*:*:* | 2.4.5 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:2.4.4:*:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:2.4.5:*:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-gv6c-59h4-9pmg silverstripe/cms (Packagist) Fixed in 2.4.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4962
- 2026-10-03 Alias added: GHSA-gv6c-59h4-9pmg
References
Advisory 2
Other 4
- [oss-security] 20120430 Re: CVE-request: SilverStripe before 2.4.4
- https://github.com/silverstripe/silverstripe-cms/commit/d15e8509b01ff2dbbe3028a055021a29b1065b22
- https://github.com/silverstripe/silverstripe-cms
- https://web.archive.org/web/20120621234353/http://doc.silverstripe.org/framework/en/trunk/changelogs/2.4.6
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
- TI-2020-05027 In SilverStripe through 4.5.0, a specific URL path configured by default through the… CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4962 · CVE Program
- CVE-2011-4962 · NVD
- FIRST EPSS
- GHSA-gv6c-59h4-9pmg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences