XpressEngine Update Query sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability was found in XpressEngine up to 1.4.4. It has been rated as critical. This issue affects some unknown processing of the component Update Query Handler. The manipulation leads to sql injection. Upgrading to version 1.4.5 is able to address this issue. The patch is named c6e94449f21256d6362450b29c7847305e756ad5. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220247.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | XpressEngine | 1.4.0; 1.4.1; 1.4.2; 1.4.3; 1.4.4 | — | No fix listed | CNA |
- XpressEngine Vendor— Affected 1.4.0; 1.4.1; 1.4.2; 1.4.3; 1.4.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xpressengine:xpressengine:*:*:*:*:*:*:*:* | before 1.4.5 | Vulnerable | Xpressengine |
- cpe:2.3:a:xpressengine:xpressengine:*:*:*:*:*:*:*:* Versions before 1.4.5 Vulnerable ·Xpressengine
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2011-10003
- 2026-10-03 Alias added: GHSA-5vgw-2vhf-f6r5
References
More Xpressengine vulnerabilities
- TI-2021-08357 XpressEngine file upload vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-20326 In XE 1.116, when uploading the Normal button, there is no restriction on the file… CVSS 3.1MEDIUM 5.4
- TI-2021-20325 XE before 1.11.6 is vulnerable to Unrestricted file upload via… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2011-10003 · CVE Program
- CVE-2011-10003 · NVD
- FIRST EPSS
- GHSA-5vgw-2vhf-f6r5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences