Read the docs
TI-2012-01610 Aliases CVE-2012-1826GHSA-42vg-q6mw-cfh5

dotCMS 1.9 before 1.9.5.1 allows remote authenticated users to execute arbitrary Java…

Priority LOW 31CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Security bypass
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

dotCMS 1.9 before 1.9.5.1 allows remote authenticated users to execute arbitrary Java code via a crafted (1) XSLT or (2) Velocity template.

Why it matters now

EPSS 0.02165 82nd percentileScored 2026-11-07
Fix Fixed com.dotcms:dotcms (Maven): 1.9.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—com.dotcms:dotcms (Maven)1.9 to before 1.9.5.11.9.5.1Patch availableGHSA-42vg-q6mw-cfh5
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • com.dotcms:dotcms (Maven) Vendor— Affected 1.9 to before 1.9.5.1 Fixed in 1.9.5.1 Patch available GHSA-42vg-q6mw-cfh5

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:dotcms:dotcms:1.9:*:*:*:*:*:*:*1.9VulnerabledotCMS
cpe:2.3:a:dotcms:dotcms:1.9.2.1:*:*:*:*:*:*:*1.9.2.1VulnerabledotCMS
  • cpe:2.3:a:dotcms:dotcms:1.9:*:*:*:*:*:*:* Versions 1.9 Vulnerable ·dotCMS
  • cpe:2.3:a:dotcms:dotcms:1.9.2.1:*:*:*:*:*:*:* Versions 1.9.2.1 Vulnerable ·dotCMS

Remediation

  • Fix · GHSA-42vg-q6mw-cfh5 com.dotcms:dotcms (Maven) Fixed in 1.9.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-1826
  2. 2026-10-03 Alias added: GHSA-42vg-q6mw-cfh5

References

  • TI-2022-09726 An issue was discovered in the ContentResource API in dotCMS 3.0 through 22.02. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-05479 dotCMS before 5.2.4 is vulnerable to directory traversal, leading to incorrect access… CVSS 3.1CRITICAL 9.8
  • TI-2020-13533 Unrestricted Upload of File with Dangerous Type in DotCMS v5.2.3 and earlier allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2017-03385 An issue was discovered in dotCMS through 3.6.1. CVSS 3.0CRITICAL 9.8
  • TI-2016-07300 SQL injection vulnerability in the categoriesServlet servlet in dotCMS before 3.3.1… CVSS 3.0CRITICAL 9.8
  • TI-2016-02117 SQL injection vulnerability in the REST API in dotCMS before 3.3.2 allows remote… CVSS 3.0CRITICAL 9.8
See all 56 →

Sources