The error function in Error.cc in poppler before 0.21.4 allows remote attackers to…
Priority LOW 39Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.
Why it matters now
EPSS 0.02942 87th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial poppler (poppler): 0.21.4Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| poppler | poppler | before 0.21.4 | 0.21.4 | Patch available | CNA |
- poppler Vendorpoppler Affected before 0.21.4 Fixed in 0.21.4 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:freedesktop:poppler:*:*:*:*:*:*:*:* | before 0.21.4 | Vulnerable | Freedesktop |
| cpe:2.3:a:xpdfreader:xpdf:3.02:*:*:*:*:*:*:* | 3.02 | Vulnerable | Xpdfreader |
| cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:opensuse:opensuse:12.2:*:*:*:*:*:*:* | 12.2 | Vulnerable | openSUSE |
- cpe:2.3:a:freedesktop:poppler:*:*:*:*:*:*:*:* Versions before 0.21.4 Vulnerable ·Freedesktop
- cpe:2.3:a:xpdfreader:xpdf:3.02:*:*:*:*:*:*:* Versions 3.02 Vulnerable ·Xpdfreader
- cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:opensuse:opensuse:12.2:*:*:*:*:*:*:* Versions 12.2 Vulnerable ·openSUSE
Remediation
- Fix · CNA poppler (poppler) Fixed in 0.21.4
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2012-2142
- 2026-10-03 Alias added: GHSA-pwcf-7grp-gwmj
References
Exploit 2
Patch 3
More poppler vulnerabilities
- TI-2009-03445 Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before… CVSS 2.0HIGH 9.3
- TI-2009-03443 Integer overflow in the PSOutputDev::doImageL1Sep function in Xpdf before 3.02pl4, and… CVSS 2.0HIGH 9.3
- TI-2009-03441 The Splash::drawImage function in Splash.cc in Xpdf 2.x and 3.x before 3.02pl4, and… CVSS 2.0HIGH 9.3
- TI-2009-03440 Integer overflow in the SplashBitmap::SplashBitmap function in Xpdf 3.x before 3.02pl4… CVSS 2.0HIGH 9.3
- TI-2009-03444 Integer overflow in the create_surface_from_thumbnail_data function in… CVSS 2.0HIGH 9.3
- TI-2008-02824 The Page destructor in Page.cc in libpoppler in Poppler 0.8.4 and earlier deletes a… CVSS 2.0HIGH 7.5
Sources
- CVE-2012-2142 · CVE Program
- CVE-2012-2142 · NVD
- FIRST EPSS
- GHSA-pwcf-7grp-gwmj · GitHub Advisory Database · CC BY 4.0
- CVE-2012-2142 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences