Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not properly handle SimpleXMLElement classes, which allows remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework1 (Packagist) | 1.0.0 to before 1.11.12 | 1.11.12 | Patch available | GHSA-7pg4-5233-82jv |
| — | zendframework/zendframework1 (Packagist) | 1.12.0-rc1 to before 1.12.0 | 1.12.0 | Patch available | GHSA-7pg4-5233-82jv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.0.0 to before 1.11.12 Fixed in 1.11.12 Patch available GHSA-7pg4-5233-82jv
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.12.0-rc1 to before 1.12.0 Fixed in 1.12.0 Patch available GHSA-7pg4-5233-82jv
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* | 1.0.0 to before 1.11.12 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.12.0:rc1:*:*:*:*:*:* | 1.12.0 rc1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.12.0:rc2:*:*:*:*:*:* | 1.12.0 rc2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.12.0:rc3:*:*:*:*:*:* | 1.12.0 rc3 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend_framework:1.12.0:rc4:*:*:*:*:*:* | 1.12.0 rc4 | Vulnerable | Zend |
| cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* | 17 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* | 18 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Debian |
- cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.11.12 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.12.0:rc1:*:*:*:*:*:* Versions 1.12.0 rc1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.12.0:rc2:*:*:*:*:*:* Versions 1.12.0 rc2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.12.0:rc3:*:*:*:*:*:* Versions 1.12.0 rc3 Vulnerable ·Zend
- cpe:2.3:a:zend:zend_framework:1.12.0:rc4:*:*:*:*:*:* Versions 1.12.0 rc4 Vulnerable ·Zend
- cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* Versions 17 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* Versions 18 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-7pg4-5233-82jv zendframework/zendframework1 (Packagist) Fixed in 1.11.12 Advisory →
- Fix · GHSA-7pg4-5233-82jv zendframework/zendframework1 (Packagist) Fixed in 1.12.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3363
- 2026-10-03 Alias added: GHSA-7pg4-5233-82jv
References
Advisory 6
Other 8
- [oss-security] 20120627 Re: XXE in Zend
- [oss-security] 20120626 Re: XXE in Zend
- [oss-security] 20120626 XXE in Zend
- [oss-security] 20130325 Moodle security notifications public
- https://www.sec-consult.com/files/20120626-0_zend_framework_xxe_injection.txt
- https://github.com/zendframework/zf1/commit/281a3251d71ed40a5289ec4afc355eea8e014dc5
- https://github.com/zendframework/zf1
- https://web.archive.org/web/20170223044943/http://www.securitytracker.com/id?1027208
Sources
- CVE-2012-3363 · CVE Program
- CVE-2012-3363 · NVD
- FIRST EPSS
- GHSA-7pg4-5233-82jv · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3363 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences