lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before…
Priority LOW 17CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which might allow remote attackers to spoof an agent by acquiring a previously used IP address.
Why it matters now
EPSS 0.01641 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial puppet (RubyGems): 2.7.18Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | puppet (RubyGems) | before 2.7.18 | 2.7.18 | Patch available | GHSA-vxf6-w9mp-95hm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- puppet (RubyGems) Vendor— Affected before 2.7.18 Fixed in 2.7.18 Patch available GHSA-vxf6-w9mp-95hm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | before 2.5.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppetlabs:puppet:*:*:*:*:*:*:*:* | before 2.7.18 | Vulnerable | Puppetlabs |
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions before 2.5.2 Vulnerable ·Puppet
- cpe:2.3:a:puppetlabs:puppet:*:*:*:*:*:*:*:* Versions before 2.7.18 Vulnerable ·Puppetlabs
Remediation
- Fix · GHSA-vxf6-w9mp-95hm puppet (RubyGems) Fixed in 2.7.18 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise MRG 1 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3408
- 2026-10-03 Alias added: GHSA-vxf6-w9mp-95hm
References
Advisory 3
Sources
- CVE-2012-3408 · CVE Program
- CVE-2012-3408 · NVD
- FIRST EPSS
- GHSA-vxf6-w9mp-95hm · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3408 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences