The (1) django.http.HttpResponseRedirect and (2)…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The (1) django.http.HttpResponseRedirect and (2) django.http.HttpResponsePermanentRedirect classes in Django before 1.3.2 and 1.4.x before 1.4.1 do not validate the scheme of a redirect target, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via a data: URL.
Why it matters now
EPSS 0.02064 81st percentileScored 2026-11-07
Fix Fixed Django (PyPI): 1.3.2, 1.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 1.3.2 | 1.3.2 | Patch available | GHSA-78vx-ggch-wghm |
| — | Django (PyPI) | 1.4 to before 1.4.1 | 1.4.1 | Patch available | GHSA-78vx-ggch-wghm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-78vx-ggch-wghm
- Django (PyPI) Vendor— Affected 1.4 to before 1.4.1 Fixed in 1.4.1 Patch available GHSA-78vx-ggch-wghm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | before 1.3.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions before 1.3.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-78vx-ggch-wghm Django (PyPI) Fixed in 1.3.2 Advisory →
- Fix · GHSA-78vx-ggch-wghm Django (PyPI) Fixed in 1.4.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3442
- 2026-10-03 Alias added: GHSA-78vx-ggch-wghm
References
Advisory 6
Other 5
- https://github.com/django/django/commit/4dea4883e6c50d75f215a6b9bcbd95273f57c72d
- https://github.com/django/django/commit/e34685034b60be1112160e76091e5aee60149fa1
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2012-2.yaml
- https://www.djangoproject.com/weblog/2012/jul/30/security-releases-issued
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2012-3442 · CVE Program
- CVE-2012-3442 · NVD
- FIRST EPSS
- GHSA-78vx-ggch-wghm · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3442 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences