lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2…
Priority LOW 12CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.
Why it matters now
EPSS 0.00481 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed puppet (RubyGems): 2.7.18
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | puppet (RubyGems) | 2.7.0 to before 2.7.18 | 2.7.18 | Patch available | GHSA-8jxj-9r5f-w3m2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- puppet (RubyGems) Vendor— Affected 2.7.0 to before 2.7.18 Fixed in 2.7.18 Patch available GHSA-8jxj-9r5f-w3m2
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.5:*:*:*:*:*:*:* | 2.7.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.6:*:*:*:*:*:*:* | 2.7.6 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.8:*:*:*:*:*:*:* | 2.7.8 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.9:*:*:*:*:*:*:* | 2.7.9 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.10:*:*:*:*:*:*:* | 2.7.10 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.11:*:*:*:*:*:*:* | 2.7.11 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.12:*:*:*:*:*:*:* | 2.7.12 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.10:*:*:*:*:*:*:* Versions 2.7.10 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.11:*:*:*:*:*:*:* Versions 2.7.11 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.12:*:*:*:*:*:*:* Versions 2.7.12 Vulnerable ·Puppet
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:2.7.13:*:*:*:*:*:*:* | 2.7.13 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.14:*:*:*:*:*:*:* | 2.7.14 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:2.7.16:*:*:*:*:*:*:* | 2.7.16 | Vulnerable | Puppet |
| cpe:2.3:a:puppetlabs:puppet:*:*:*:*:*:*:*:* | up to 2.7.17 | Vulnerable | Puppetlabs |
| cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Puppetlabs |
| cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Puppetlabs |
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | up to 2.5.1 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet:2.7.13:*:*:*:*:*:*:* Versions 2.7.13 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.14:*:*:*:*:*:*:* Versions 2.7.14 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:2.7.16:*:*:*:*:*:*:* Versions 2.7.16 Vulnerable ·Puppet
- cpe:2.3:a:puppetlabs:puppet:*:*:*:*:*:*:*:* Versions up to 2.7.17 Vulnerable ·Puppetlabs
- cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Puppetlabs
- cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Puppetlabs
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions up to 2.5.1 Vulnerable ·Puppet
Remediation
- Fix · GHSA-8jxj-9r5f-w3m2 puppet (RubyGems) Fixed in 2.7.18 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3866
- 2026-10-03 Alias added: GHSA-8jxj-9r5f-w3m2
References
Advisory 5
Other 5
- https://bugzilla.redhat.com/show_bug.cgi?id=839135
- https://github.com/puppetlabs/puppet
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-3866.yml
- https://www.puppet.com/security/cve/cve-2012-3866-lastrunreportyaml-world-readable
- http://puppetlabs.com/security/cve/cve-2012-3866
Sources
- CVE-2012-3866 · CVE Program
- CVE-2012-3866 · NVD
- FIRST EPSS
- GHSA-8jxj-9r5f-w3m2 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3866 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences