Read the docs
TI-2012-03337 Aliases CVE-2012-3868GHSA-v87w-rgf8-76jc

Race condition in the ns_client structure management in ISC BIND 9.9.x before 9.9.1-P2…

Priority LOW 25CWE-362Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA.

Summary

Race condition in the ns_client structure management in ISC BIND 9.9.x before 9.9.1-P2 allows remote attackers to cause a denial of service (memory consumption or process exit) via a large volume of TCP queries.

Why it matters now

EPSS 0.02722 86th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.0:*:*:*:*:*:*:*9.9.0VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:a1:*:*:*:*:*:*9.9.0 a1VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:a2:*:*:*:*:*:*9.9.0 a2VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:a3:*:*:*:*:*:*9.9.0 a3VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:b1:*:*:*:*:*:*9.9.0 b1VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:b2:*:*:*:*:*:*9.9.0 b2VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:rc1:*:*:*:*:*:*9.9.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:rc2:*:*:*:*:*:*9.9.0 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:rc3:*:*:*:*:*:*9.9.0 rc3VulnerableISC
cpe:2.3:a:isc:bind:9.9.0:rc4:*:*:*:*:*:*9.9.0 rc4VulnerableISC
  • cpe:2.3:a:isc:bind:9.9.0:*:*:*:*:*:*:* Versions 9.9.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:a1:*:*:*:*:*:* Versions 9.9.0 a1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:a2:*:*:*:*:*:* Versions 9.9.0 a2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:a3:*:*:*:*:*:* Versions 9.9.0 a3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:b1:*:*:*:*:*:* Versions 9.9.0 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:b2:*:*:*:*:*:* Versions 9.9.0 b2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:rc1:*:*:*:*:*:* Versions 9.9.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:rc2:*:*:*:*:*:* Versions 9.9.0 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:rc3:*:*:*:*:*:* Versions 9.9.0 rc3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.0:rc4:*:*:*:*:*:* Versions 9.9.0 rc4 Vulnerable ·ISC
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.1:*:*:*:*:*:*:*9.9.1VulnerableISC
cpe:2.3:a:isc:bind:9.9.1:p1:*:*:*:*:*:*9.9.1 p1VulnerableISC
  • cpe:2.3:a:isc:bind:9.9.1:*:*:*:*:*:*:* Versions 9.9.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.1:p1:*:*:*:*:*:* Versions 9.9.1 p1 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-3868
  2. 2026-10-03 Alias added: GHSA-v87w-rgf8-76jc

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources