Incorrect default permissions in fwknop
Priority MEDIUM 44CWE-276Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.
Why it matters now
EPSS 0.03311 88th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed fwknop (fwknop): 2.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fwknop | fwknop | before 2.0.3 | 2.0.3 | Patch available | CNA |
- fwknop Vendorfwknop Affected before 2.0.3 Fixed in 2.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cipherdyne:fwknop:*:*:*:*:*:*:*:* | before 2.0.3 | Vulnerable | Cipherdyne |
- cpe:2.3:a:cipherdyne:fwknop:*:*:*:*:*:*:*:* Versions before 2.0.3 Vulnerable ·Cipherdyne
Remediation
- Fix · CNA fwknop (fwknop) Fixed in 2.0.3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-4434
- 2026-10-03 Alias added: GHSA-hh46-vfhf-rqg7
References
More Cipherdyne Fwknop vulnerabilities
- TI-2012-03777 fwknop before 2.0.3 does not properly validate IP addresses, which allows remote… CVSS 2.0MEDIUM 4.0
- TI-2012-03778 Buffer overflow in the run_last_args function in client/fwknop.c in fwknop before 2.0.3… CVSS 2.0MEDIUM 4.4
Sources
- CVE-2012-4434 · CVE Program
- CVE-2012-4434 · NVD
- FIRST EPSS
- GHSA-hh46-vfhf-rqg7 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-4434 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences