The default configuration for Apache Qpid 0.20 and earlier, when the federation_tag…
Priority LOW 38CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Partial Red Hat: 11 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
The default configuration for Apache Qpid 0.20 and earlier, when the federation_tag attribute is enabled, accepts AMQP connections without checking the source user ID, which allows remote attackers to bypass authentication and have other unspecified impact via an AMQP request.
Why it matters now
EPSS 0.04913 92nd percentileScored 2026-11-07
Fix Partial org.apache.qpid:qpid-client (Maven): 0.20Red Hat: 2 advisoriesRed Hat: 11 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.qpid:qpid-client (Maven) | before 0.20 | 0.20 | Patch available | GHSA-mrgh-6x42-x6xf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.qpid:qpid-client (Maven) Vendor— Affected before 0.20 Fixed in 0.20 Patch available GHSA-mrgh-6x42-x6xf
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:qpid:*:*:*:*:*:*:*:* | up to 0.20 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.5:*:*:*:*:*:*:* | 0.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.6:*:*:*:*:*:*:* | 0.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.7:*:*:*:*:*:*:* | 0.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.8:*:*:*:*:*:*:* | 0.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.9:*:*:*:*:*:*:* | 0.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.10:*:*:*:*:*:*:* | 0.10 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.11:*:*:*:*:*:*:* | 0.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.12:*:*:*:*:*:*:* | 0.12 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.13:*:*:*:*:*:*:* | 0.13 | Vulnerable | Apache |
- cpe:2.3:a:apache:qpid:*:*:*:*:*:*:*:* Versions up to 0.20 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.5:*:*:*:*:*:*:* Versions 0.5 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.6:*:*:*:*:*:*:* Versions 0.6 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.7:*:*:*:*:*:*:* Versions 0.7 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.8:*:*:*:*:*:*:* Versions 0.8 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.9:*:*:*:*:*:*:* Versions 0.9 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.10:*:*:*:*:*:*:* Versions 0.10 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.11:*:*:*:*:*:*:* Versions 0.11 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.12:*:*:*:*:*:*:* Versions 0.12 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.13:*:*:*:*:*:*:* Versions 0.13 Vulnerable ·Apache
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:qpid:0.14:*:*:*:*:*:*:* | 0.14 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.15:*:*:*:*:*:*:* | 0.15 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.16:*:*:*:*:*:*:* | 0.16 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.17:*:*:*:*:*:*:* | 0.17 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.18:*:*:*:*:*:*:* | 0.18 | Vulnerable | Apache |
| cpe:2.3:a:apache:qpid:0.19:*:*:*:*:*:*:* | 0.19 | Vulnerable | Apache |
- cpe:2.3:a:apache:qpid:0.14:*:*:*:*:*:*:* Versions 0.14 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.15:*:*:*:*:*:*:* Versions 0.15 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.16:*:*:*:*:*:*:* Versions 0.16 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.17:*:*:*:*:*:*:* Versions 0.17 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.18:*:*:*:*:*:*:* Versions 0.18 Vulnerable ·Apache
- cpe:2.3:a:apache:qpid:0.19:*:*:*:*:*:*:* Versions 0.19 Vulnerable ·Apache
Remediation
- Fix · GHSA-mrgh-6x42-x6xf org.apache.qpid:qpid-client (Maven) Fixed in 0.20 Advisory →
Red Hat 2 advisories
- RHSA-2013:0562 Released 2013-03-06 · Red Hat rating ModerateRed Hat Enterprise MRG Messaging 2.3 security update
- Red Hat MRG Grid Execute Node for RHEL 6 ComputeNode v.2 mrg-release-2.3.0-1.el6, python-qpid-0.18-4.el6, python-qpid-qmf-0.18-15.el6 +21
- Red Hat MRG Grid Execute Node for RHEL 6 Server v.2 mrg-release-2.3.0-1.el6
- Red Hat MRG Grid for RHEL 6 Server v.2 mrg-release-2.3.0-1.el6, rubygem-rake-0.8.7-2.1.el6, rubygems-1.8.16-1.el6
- Red Hat MRG Management for RHEL 6 ComputeNode v.2 mrg-release-2.3.0-1.el6
- Red Hat MRG Management for RHEL 6 Server v.2 cumin-messaging-0.1.1-2.el6, mrg-release-2.3.0-1.el6
- Red Hat MRG Messaging for RHEL 6 Server v.2 mrg-release-2.3.0-1.el6, python-qpid-0.18-4.el6, python-qpid-qmf-0.18-15.el6 +35
- Red Hat MRG Realtime for RHEL 6 Server v.2 mrg-release-2.3.0-1.el6
- RHSA-2013:0561 Released 2013-03-06 · Red Hat rating ModerateRed Hat Enterprise MRG Messaging 2.3 security update
- MRG Grid Execute Node for RHEL 5 Server v.2 mrg-release-2.3.0-1.el5
- MRG Grid for RHEL 5 Server v.2 mrg-release-2.3.0-1.el5
- MRG Management for RHEL 5 Server v.2 cumin-messaging-0.1.1-2.el5, mrg-release-2.3.0-1.el5
- Red Hat MRG Messaging for RHEL 5 Server v.2 mrg-release-2.3.0-1.el5, python-qpid-0.18-4.el5, python-qpid-qmf-0.18-15.el5 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix yet |
| MRG Grid Execute Node for RHEL 5 Server v.2 | Fixed | RHSA-2013:0561 |
| MRG Grid for RHEL 5 Server v.2 | Fixed | RHSA-2013:0561 |
| MRG Management for RHEL 5 Server v.2 | Fixed | RHSA-2013:0561 |
| Red Hat MRG Grid Execute Node for RHEL 6 ComputeNode v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Grid Execute Node for RHEL 6 Server v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Grid for RHEL 6 Server v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Management for RHEL 6 ComputeNode v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Management for RHEL 6 Server v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Messaging for RHEL 5 Server v.2 | Fixed | RHSA-2013:0561 |
| Red Hat MRG Messaging for RHEL 6 Server v.2 | Fixed | RHSA-2013:0562 |
| Red Hat MRG Realtime for RHEL 6 Server v.2 | Fixed | RHSA-2013:0562 |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-4446
- 2026-10-03 Alias added: GHSA-mrgh-6x42-x6xf
References
More Apache Qpid vulnerabilities
- TI-2015-00196 qpidd in Apache Qpid 0.30 and earlier allows remote attackers to cause a denial of… CVSS 3.0HIGH 7.5
- TI-2019-00196 While investigating bug PROTON-2014, we discovered that under some circumstances Apache… CVSS 3.1HIGH 7.4
- TI-2011-03194 Apache Qpid 0.12 does not properly verify credentials during the joining of a cluster… CVSS 2.0HIGH 7.5
- TI-2015-00175 The qpidd broker in Apache Qpid 0.30 and earlier allows remote authenticated users to… CVSS 3.0MEDIUM 6.5
- TI-2012-03801 Integer overflow in the qpid::framing::Buffer::checkAvailable function in Apache Qpid… CVSS 2.0MEDIUM 5.0
- TI-2015-00195 Unspecified vulnerability in Apache Qpid 0.30 and earlier allows remote attackers to… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2012-4446 · CVE Program
- CVE-2012-4446 · NVD
- FIRST EPSS
- GHSA-mrgh-6x42-x6xf · GitHub Advisory Database · CC BY 4.0
- CVE-2012-4446 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences