Freeciv before 2.3.3 allows remote attackers to cause a denial of service via a crafted packet.
Priority MEDIUM 46CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-400.
Summary
Freeciv before 2.3.3 allows remote attackers to cause a denial of service via a crafted packet.
Why it matters now
EPSS 0.11734 96th percentileScored 2026-11-07
Fix Fixed freeciv (freeciv): 2.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA freeciv (freeciv) Fixed in 2.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2012-6083
- 2026-10-03 Alias added: GHSA-4c5q-v3gj-45mr
References
More Freeciv vulnerabilities
- TI-2010-02348 freeciv 2.2 before 2.2.1 and 2.3 before 2.3.0 allows attackers to read arbitrary files or… CVSS 2.0HIGH 10.0
- TI-2022-18439 Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the… CVSS 3.1HIGH 8.8
- TI-2006-03789 Buffer overflow in Freeciv 2.1.0-beta1 and earlier, and SVN 15 Jul 2006 and earlier… CVSS 2.0HIGH 7.5
- TI-2012-04746 Uncontrolled resource consumption in freeciv CVSS 3.1HIGH 7.5
- TI-2006-00042 packets.c in Freeciv 2.0 before 2.0.8 allows remote attackers to cause a denial of… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2012-6083 · CVE Program
- CVE-2012-6083 · NVD
- FIRST EPSS
- GHSA-4c5q-v3gj-45mr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences