Cross-site request forgery (CSRF) vulnerability in the omniauth-oauth2 gem 1.1.1 and…
Priority LOW 32CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-site request forgery (CSRF) vulnerability in the omniauth-oauth2 gem 1.1.1 and earlier for Ruby allows remote attackers to hijack the authentication of users for requests that modify session state.
Why it matters now
EPSS 0.01196 68th percentileScored 2026-11-07
Fix Fixed omniauth-oauth2 (RubyGems): 1.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | omniauth-oauth2 (RubyGems) | before 1.1.1 | 1.1.1 | Patch available | GHSA-fgmx-8h93-26fh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- omniauth-oauth2 (RubyGems) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-fgmx-8h93-26fh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:omniauth-oauth2_project:omniauth-oauth2:*:*:*:*:*:ruby:*:* | before 1.1.1 | Vulnerable | Omniauth-oauth2 Project |
- cpe:2.3:a:omniauth-oauth2_project:omniauth-oauth2:*:*:*:*:*:ruby:*:* Versions before 1.1.1 Vulnerable ·Omniauth-oauth2 Project
Remediation
- Fix · GHSA-fgmx-8h93-26fh omniauth-oauth2 (RubyGems) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2012-6134
- 2026-10-03 Alias added: GHSA-fgmx-8h93-26fh
References
Patch 2
Advisory 2
Other 6
- http://rubysec.github.io/advisories/CVE-2012-6134/
- https://gist.github.com/homakov/3673012
- https://github.com/Shopify/omniauth-shopify-oauth2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-oauth2/CVE-2012-6134.yml
- https://web.archive.org/web/20170312020947/https://gist.github.com/homakov/3673012
- http://rubysec.github.io/advisories/CVE-2012-6134
Sources
- CVE-2012-6134 · CVE Program
- CVE-2012-6134 · NVD
- FIRST EPSS
- GHSA-fgmx-8h93-26fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences