Cross-site scripting (XSS) vulnerability in the default content option in…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 13 fixed, 10 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title attribute, which is not properly handled in the autocomplete combo box demo.
Why it matters now
EPSS 0.07475 94th percentileScored 2026-11-07
Fix Partial jquery-ui (npm): 1.10.0jquery-ui-rails (RubyGems): 4.0.0+2 more productsRed Hat: 2 advisoriesRed Hat: 13 fixed, 10 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jquery-ui (npm) | before 1.10.0 | 1.10.0 | Patch available | GHSA-qqxp-xp9v-vvx6 |
| — | jquery-ui-rails (RubyGems) | before 4.0.0 | 4.0.0 | Patch available | GHSA-qqxp-xp9v-vvx6 |
| — | org.webjars.npm:jquery-ui (Maven) | before 1.10.0 | 1.10.0 | Patch available | GHSA-qqxp-xp9v-vvx6 |
| — | jQuery.UI.Combined (NuGet) | before 1.10.0 | 1.10.0 | Patch available | GHSA-qqxp-xp9v-vvx6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jquery-ui (npm) Vendor— Affected before 1.10.0 Fixed in 1.10.0 Patch available GHSA-qqxp-xp9v-vvx6
- jquery-ui-rails (RubyGems) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-qqxp-xp9v-vvx6
- org.webjars.npm:jquery-ui (Maven) Vendor— Affected before 1.10.0 Fixed in 1.10.0 Patch available GHSA-qqxp-xp9v-vvx6
- jQuery.UI.Combined (NuGet) Vendor— Affected before 1.10.0 Fixed in 1.10.0 Patch available GHSA-qqxp-xp9v-vvx6
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_hpc_node:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:a:jqueryui:jquery_ui:1.10.0:rc1:*:*:*:jquery:*:* | 1.10.0 rc1 | Vulnerable | Jqueryui |
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_hpc_node:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:a:jqueryui:jquery_ui:1.10.0:rc1:*:*:*:jquery:*:* Versions 1.10.0 rc1 Vulnerable ·Jqueryui
Remediation
- Fix · GHSA-qqxp-xp9v-vvx6 jquery-ui (npm) Fixed in 1.10.0 Advisory →
- Fix · GHSA-qqxp-xp9v-vvx6 jquery-ui-rails (RubyGems) Fixed in 4.0.0 Advisory →
- Fix · GHSA-qqxp-xp9v-vvx6 org.webjars.npm:jquery-ui (Maven) Fixed in 1.10.0 Advisory →
- Fix · GHSA-qqxp-xp9v-vvx6 jQuery.UI.Combined (NuGet) Fixed in 1.10.0 Advisory →
Red Hat 2 advisories
- RHSA-2015:1462 Released 2015-07-21 · Red Hat rating Moderateipa security and bug fix update
- Red Hat Enterprise Linux Desktop (v. 6) ipa-3.0.0-47.el6, ipa-client-3.0.0-47.el6, ipa-python-3.0.0-47.el6
- Red Hat Enterprise Linux Desktop Optional (v. 6) ipa-admintools-3.0.0-47.el6, ipa-server-3.0.0-47.el6, ipa-server-selinux-3.0.0-47.el6 +1
- Red Hat Enterprise Linux HPC Node (v. 6) ipa-3.0.0-47.el6, ipa-client-3.0.0-47.el6, ipa-python-3.0.0-47.el6
- Red Hat Enterprise Linux HPC Node Optional (v. 6) ipa-admintools-3.0.0-47.el6, ipa-server-3.0.0-47.el6, ipa-server-selinux-3.0.0-47.el6 +1
- Red Hat Enterprise Linux Server (v. 6) ipa-3.0.0-47.el6, ipa-admintools-3.0.0-47.el6, ipa-client-3.0.0-47.el6 +4
- Red Hat Enterprise Linux Workstation (v. 6) ipa-3.0.0-47.el6, ipa-admintools-3.0.0-47.el6, ipa-client-3.0.0-47.el6 +4
- RHSA-2015:0442 Released 2015-03-05 · Red Hat rating Moderateipa security, bug fix, and enhancement update
- Red Hat Enterprise Linux Client (v. 7) ipa-4.1.0-18.el7, ipa-client-4.1.0-18.el7, ipa-python-4.1.0-18.el7
- Red Hat Enterprise Linux Client Optional (v. 7) ipa-admintools-4.1.0-18.el7, ipa-server-4.1.0-18.el7, ipa-server-trust-ad-4.1.0-18.el7
- Red Hat Enterprise Linux ComputeNode (v. 7) ipa-4.1.0-18.el7, ipa-client-4.1.0-18.el7, ipa-python-4.1.0-18.el7
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) ipa-admintools-4.1.0-18.el7, ipa-server-4.1.0-18.el7, ipa-server-trust-ad-4.1.0-18.el7
- Red Hat Enterprise Linux Server (v. 7) ipa-4.1.0-18.el7, ipa-admintools-4.1.0-18.el7, ipa-client-4.1.0-18.el7 +3
- Red Hat Enterprise Linux Server Optional (v. 7) ipa-admintools-4.1.0-18.el7
- Red Hat Enterprise Linux Workstation (v. 7) ipa-4.1.0-18.el7, ipa-admintools-4.1.0-18.el7, ipa-client-4.1.0-18.el7 +3
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| OpenStack Foreman | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux Desktop (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux Desktop Optional (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux HPC Node (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux HPC Node Optional (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2015:0442 |
| Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2015:1462 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2015:0442 |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-6662
- 2026-10-03 Alias added: GHSA-qqxp-xp9v-vvx6
References
Patch 2
Advisory 7
Sources
- CVE-2012-6662 · CVE Program
- CVE-2012-6662 · NVD
- FIRST EPSS
- GHSA-qqxp-xp9v-vvx6 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-6662 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences