Nokogiri before 1.5.4 is vulnerable to XXE attacks
Priority LOW 37CWE-776Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 fixed, 7 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Nokogiri before 1.5.4 is vulnerable to XXE attacks
Why it matters now
EPSS 0.02168 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial nokogiri (RubyGems): 1.5.4Red Hat: 1 advisoryRed Hat: 1 fixed, 7 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nokogiri (RubyGems) | before 1.5.4 | 1.5.4 | Patch available | GHSA-6wj9-77wq-jq7p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nokogiri (RubyGems) Vendor— Affected before 1.5.4 Fixed in 1.5.4 Patch available GHSA-6wj9-77wq-jq7p
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nokogiri:nokogiri:*:*:*:*:*:*:*:* | before 1.5.4 | Vulnerable | sparklemotion |
| cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift:2.0:*:*:*:enterprise:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack_foreman:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:subscription_asset_manager:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_mrg:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Red Hat |
- cpe:2.3:a:nokogiri:nokogiri:*:*:*:*:*:*:*:* Versions before 1.5.4 Vulnerable ·sparklemotion
- cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift:2.0:*:*:*:enterprise:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack_foreman:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Red Hat
- cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:subscription_asset_manager:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_mrg:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-6wj9-77wq-jq7p nokogiri (RubyGems) Fixed in 1.5.4 Advisory →
Red Hat 1 advisory
- RHSA-2019:0212 Released 2019-02-07 · Red Hat rating ModerateCloudForms 4.7 security, bug fix and enhancement update
- CloudForms Management Engine 5.10 ansible-runner-1.1.2-2.el7ar, ansible-tower-3.3.3-1.el7at, ansible-tower-server-3.3.3-1.el7at +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenStack Foreman | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) Installer | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise MRG 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| CloudForms Management Engine 5.10 | Fixed | RHSA-2019:0212 |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-6685
- 2026-10-03 Alias added: GHSA-6wj9-77wq-jq7p
References
Sources
- CVE-2012-6685 · CVE Program
- CVE-2012-6685 · NVD
- FIRST EPSS
- GHSA-6wj9-77wq-jq7p · GitHub Advisory Database · CC BY 4.0
- CVE-2012-6685 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences