HD FLV PLayer Plugin functions.php hd_update_media sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability was found in HD FLV PLayer Plugin up to 1.7 on WordPress. It has been rated as critical. Affected by this issue is the function hd_add_media/hd_update_media of the file functions.php. The manipulation of the argument name leads to sql injection. The attack may be launched remotely. Upgrading to version 1.8 is able to address this issue. The patch is identified as 34d66b9f3231a0e2dc0e536a6fe615d736e863f7. It is recommended to upgrade the affected component. VDB-225350 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | HD FLV PLayer Plugin | 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7 | — | No fix listed | CNA |
- HD FLV PLayer Plugin Vendor— Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2012-10011
- 2026-10-03 Alias added: GHSA-7jrm-37ff-g3mp
References
Sources
- CVE-2012-10011 · CVE Program
- CVE-2012-10011 · NVD
- FIRST EPSS
- GHSA-7jrm-37ff-g3mp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences