BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BestWebSoft | Twitter Plugin | 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14 | — | No fix listed | CNA |
- Twitter Plugin VendorBestWebSoft Affected 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bestwebsoft:twitter:*:*:*:*:*:wordpress:*:* | before 2.15 | Vulnerable | BestWebSoft |
- cpe:2.3:a:bestwebsoft:twitter:*:*:*:*:*:wordpress:*:* Versions before 2.15 Vulnerable ·BestWebSoft
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2012-10015
- 2026-10-03 Alias added: GHSA-vjqm-g4gj-9mj4
References
More BestWebSoft Twitter vulnerabilities
- TI-2014-08403 BestWebSoft Twitter Plugin twitter.php twttr_settings_page cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2012-10015 · CVE Program
- CVE-2012-10015 · NVD
- FIRST EPSS
- GHSA-vjqm-g4gj-9mj4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences