PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
Why it matters now
EPSS 0.00822 57th percentileScored 2026-11-07
Fix Fixed prestashop/prestashop (Packagist): 1.5.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | prestashop/prestashop (Packagist) | before 1.5.2.0 | 1.5.2.0 | Patch available | GHSA-j33m-2537-86jm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- prestashop/prestashop (Packagist) Vendor— Affected before 1.5.2.0 Fixed in 1.5.2.0 Patch available GHSA-j33m-2537-86jm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* | before 1.5.2 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 1.5.2 Vulnerable ·PrestaShop
Remediation
- Fix · GHSA-j33m-2537-86jm prestashop/prestashop (Packagist) Fixed in 1.5.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2012-20001
- 2026-10-03 Alias added: GHSA-j33m-2537-86jm
References
More Prestashop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
- TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
- TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2012-20001 · CVE Program
- CVE-2012-20001 · NVD
- FIRST EPSS
- GHSA-j33m-2537-86jm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences