Ruby agent 3.2.0 through 3.5.2 serializes sensitive data when communicating with servers…
Priority LOW 25CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Ruby agent 3.2.0 through 3.5.2 serializes sensitive data when communicating with servers operated by New Relic, which allows remote attackers to obtain sensitive information (database credentials and SQL statements) by sniffing the network and deserializing the data.
Why it matters now
EPSS 0.01252 69th percentileScored 2026-11-07
Fix Fixed newrelic_rpm (RubyGems): 3.5.3.24
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | newrelic_rpm (RubyGems) | 3.2.0 to before 3.5.3.24 | 3.5.3.24 | Patch available | GHSA-q6cw-2553-7837 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- newrelic_rpm (RubyGems) Vendor— Affected 3.2.0 to before 3.5.3.24 Fixed in 3.5.3.24 Patch available GHSA-q6cw-2553-7837
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:newrelic:ruby_agent:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.2:*:*:*:*:*:*:* | 3.3.2 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.2.1:*:*:*:*:*:*:* | 3.3.2.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.3:*:*:*:*:*:*:* | 3.3.3 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.4:*:*:*:*:*:*:* | 3.3.4 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.4.1:*:*:*:*:*:*:* | 3.3.4.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.3.5:*:*:*:*:*:*:* | 3.3.5 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.4.0:*:*:*:*:*:*:* | 3.4.0 | Vulnerable | Newrelic |
- cpe:2.3:a:newrelic:ruby_agent:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.2:*:*:*:*:*:*:* Versions 3.3.2 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.2.1:*:*:*:*:*:*:* Versions 3.3.2.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.3:*:*:*:*:*:*:* Versions 3.3.3 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.4:*:*:*:*:*:*:* Versions 3.3.4 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.4.1:*:*:*:*:*:*:* Versions 3.3.4.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.3.5:*:*:*:*:*:*:* Versions 3.3.5 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·Newrelic
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:newrelic:ruby_agent:3.4.0.1:*:*:*:*:*:*:* | 3.4.0.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.4.1:*:*:*:*:*:*:* | 3.4.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.4.2:*:*:*:*:*:*:* | 3.4.2 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.4.2.1:*:*:*:*:*:*:* | 3.4.2.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.5.0:*:*:*:*:*:*:* | 3.5.0 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.5.0.1:*:*:*:*:*:*:* | 3.5.0.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.5.1:*:*:*:*:*:*:* | 3.5.1 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.5.1.14:*:*:*:*:*:*:* | 3.5.1.14 | Vulnerable | Newrelic |
| cpe:2.3:a:newrelic:ruby_agent:3.5.2:*:*:*:*:*:*:* | 3.5.2 | Vulnerable | Newrelic |
- cpe:2.3:a:newrelic:ruby_agent:3.4.0.1:*:*:*:*:*:*:* Versions 3.4.0.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.4.1:*:*:*:*:*:*:* Versions 3.4.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.4.2:*:*:*:*:*:*:* Versions 3.4.2 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.4.2.1:*:*:*:*:*:*:* Versions 3.4.2.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.5.0:*:*:*:*:*:*:* Versions 3.5.0 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.5.0.1:*:*:*:*:*:*:* Versions 3.5.0.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.5.1:*:*:*:*:*:*:* Versions 3.5.1 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.5.1.14:*:*:*:*:*:*:* Versions 3.5.1.14 Vulnerable ·Newrelic
- cpe:2.3:a:newrelic:ruby_agent:3.5.2:*:*:*:*:*:*:* Versions 3.5.2 Vulnerable ·Newrelic
Remediation
- Fix · GHSA-q6cw-2553-7837 newrelic_rpm (RubyGems) Fixed in 3.5.3.24 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-0284
- 2026-10-03 Alias added: GHSA-q6cw-2553-7837
References
Advisory 2
Other 4
Sources
- CVE-2013-0284 · CVE Program
- CVE-2013-0284 · NVD
- FIRST EPSS
- GHSA-q6cw-2553-7837 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences