The administrative interface for Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5…
Priority LOW 23CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
The administrative interface for Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 does not check permissions for the history view, which allows remote authenticated administrators to obtain sensitive object history information.
Why it matters now
EPSS 0.01855 79th percentileScored 2026-11-07
Fix Partial Django (PyPI): 1.3.6, 1.4.4Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.3 to before 1.3.6 | 1.3.6 | Patch available | GHSA-r7w6-p47g-vj53 |
| — | Django (PyPI) | 1.4 to before 1.4.4 | 1.4.4 | Patch available | GHSA-r7w6-p47g-vj53 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.3 to before 1.3.6 Fixed in 1.3.6 Patch available GHSA-r7w6-p47g-vj53
- Django (PyPI) Vendor— Affected 1.4 to before 1.4.4 Fixed in 1.4.4 Patch available GHSA-r7w6-p47g-vj53
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.3:*:*:*:*:*:*:* | 1.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3:alpha1:*:*:*:*:*:* | 1.3 alpha1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3:beta1:*:*:*:*:*:* | 1.3 beta1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3.2:*:*:*:*:*:*:* | 1.3.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3.3:*:*:*:*:*:*:* | 1.3.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4:alpha:*:*:*:*:*:* | 1.4 alpha | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4:beta:*:*:*:*:*:* | 1.4 beta | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:* | 1.4.1 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.3:*:*:*:*:*:*:* Versions 1.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3:alpha1:*:*:*:*:*:* Versions 1.3 alpha1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3:beta1:*:*:*:*:*:* Versions 1.3 beta1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3.2:*:*:*:*:*:*:* Versions 1.3.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3.3:*:*:*:*:*:*:* Versions 1.3.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4:alpha:*:*:*:*:*:* Versions 1.4 alpha Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4:beta:*:*:*:*:*:* Versions 1.4 beta Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:* Versions 1.4.1 Vulnerable ·djangoproject
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:* | 1.4.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:* | 1.5 alpha | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:* | 1.5 beta | Vulnerable | djangoproject |
| cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:* | 10.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:11.10:*:*:*:*:*:*:* | 11.10 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:* | 12.10 | Vulnerable | Canonical |
- cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:* Versions 1.4.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:* Versions 1.5 alpha Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:* Versions 1.5 beta Vulnerable ·djangoproject
- cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:* Versions 10.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:11.10:*:*:*:*:*:*:* Versions 11.10 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:* Versions 12.10 Vulnerable ·Canonical
Remediation
- Fix · GHSA-r7w6-p47g-vj53 Django (PyPI) Fixed in 1.3.6 Advisory →
- Fix · GHSA-r7w6-p47g-vj53 Django (PyPI) Fixed in 1.4.4 Advisory →
Red Hat 1 advisory
- RHSA-2013:0670 Released 2013-03-21 · Red Hat rating ModerateDjango security update
- OpenStack Folsom Django14-1.4.4-1.el6ost, Django14-doc-1.4.4-1.el6ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Subscription Asset Manager | Affected | No fix yet |
| OpenStack Folsom | Fixed | RHSA-2013:0670 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-0305
- 2026-10-03 Alias added: GHSA-r7w6-p47g-vj53
References
Other 5
- https://github.com/django/django/commit/0e7861aec73702f7933ce2a93056f7983939f0d6
- https://github.com/django/django/commit/d3a45e10c8ac8268899999129daa27652ec0da35
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2013-16.yaml
- https://www.djangoproject.com/weblog/2013/feb/19/security
Sources
- CVE-2013-0305 · CVE Program
- CVE-2013-0305 · NVD
- FIRST EPSS
- GHSA-r7w6-p47g-vj53 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-0305 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences