Bundler before 1.7, when multiple top-level source lines are used, allows remote…
Priority LOW 30CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 8 fixed, 7 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.
Why it matters now
EPSS 0.04303 91st percentileScored 2026-11-07
Fix Partial bundler (RubyGems): 1.7.0Red Hat: 1 advisoryRed Hat: 8 fixed, 7 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | bundler (RubyGems) | before 1.7.0 | 1.7.0 | Patch available | GHSA-49jx-9cmc-xjxm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- bundler (RubyGems) Vendor— Affected before 1.7.0 Fixed in 1.7.0 Patch available GHSA-49jx-9cmc-xjxm
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bundler:bundler:*:*:*:*:*:ruby:*:* | before 1.7.0 | Vulnerable | Bundler |
| cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* | 13.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
| cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* | 19 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* | 20 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* | 21 | Vulnerable | Fedoraproject |
- cpe:2.3:a:bundler:bundler:*:*:*:*:*:ruby:*:* Versions before 1.7.0 Vulnerable ·Bundler
- cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
- cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* Versions 19 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* Versions 20 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* Versions 21 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-49jx-9cmc-xjxm bundler (RubyGems) Fixed in 1.7.0 Advisory →
Red Hat 1 advisory
- RHSA-2015:2180 Released 2015-11-19 · Red Hat rating Moderaterubygem-bundler and rubygem-thor security, bug fix, and enhancement update
- Red Hat Enterprise Linux Client (v. 7) rubygem-bundler-1.7.8-3.el7, rubygem-thor-0.19.1-1.el7
- Red Hat Enterprise Linux Client Optional (v. 7) rubygem-bundler-doc-1.7.8-3.el7, rubygem-thor-doc-0.19.1-1.el7
- Red Hat Enterprise Linux ComputeNode (v. 7) rubygem-bundler-1.7.8-3.el7, rubygem-thor-0.19.1-1.el7
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) rubygem-bundler-doc-1.7.8-3.el7, rubygem-thor-doc-0.19.1-1.el7
- Red Hat Enterprise Linux Server (v. 7) rubygem-bundler-1.7.8-3.el7, rubygem-thor-0.19.1-1.el7
- Red Hat Enterprise Linux Server Optional (v. 7) rubygem-bundler-doc-1.7.8-3.el7, rubygem-thor-doc-0.19.1-1.el7
- Red Hat Enterprise Linux Workstation (v. 7) rubygem-bundler-1.7.8-3.el7, rubygem-thor-0.19.1-1.el7
- Red Hat Enterprise Linux Workstation Optional (v. 7) rubygem-bundler-doc-1.7.8-3.el7, rubygem-thor-doc-0.19.1-1.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| OpenStack Foreman | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2015:2180 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2015:2180 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-0334
- 2026-10-03 Alias added: GHSA-49jx-9cmc-xjxm
- 2026-10-12 EPSS moved to the 90th–95th percentile
References
Advisory 8
- GLSA-201609-02
- FEDORA-2014-11649
- FEDORA-2014-11630
- http://bundler.io/blog/2014/08/14/bundler-may-install-gems-from-a-different-source-than-expected-cve-2013-0334.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- FEDORA-2014-11677
- openSUSE-SU-2015:0628
- https://nvd.nist.gov/vuln/detail/CVE-2013-0334
Sources
- CVE-2013-0334 · CVE Program
- CVE-2013-0334 · NVD
- FIRST EPSS
- GHSA-49jx-9cmc-xjxm · GitHub Advisory Database · CC BY 4.0
- CVE-2013-0334 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences