Read the docs
TI-2013-01414 Aliases CVE-2013-1607GHSA-39v7-xpq4-8884

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Priority MEDIUM 47CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Why it matters now

EPSS 0.02675 85th percentileScored 2026-11-07
Fix Fixed pdfkit (RubyGems): 0.5.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—pdfkit (RubyGems)before 0.5.30.5.3Patch availableGHSA-39v7-xpq4-8884
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • pdfkit (RubyGems) Vendor— Affected before 0.5.3 Fixed in 0.5.3 Patch available GHSA-39v7-xpq4-8884

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pdfkit_project:pdfkit:*:*:*:*:*:ruby:*:*before 0.5.3VulnerablePdfkit Project
  • cpe:2.3:a:pdfkit_project:pdfkit:*:*:*:*:*:ruby:*:* Versions before 0.5.3 Vulnerable ·Pdfkit Project

Remediation

  • Fix · GHSA-39v7-xpq4-8884 pdfkit (RubyGems) Fixed in 0.5.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-1607
  2. 2026-10-03 Alias added: GHSA-39v7-xpq4-8884

References

Sources