pyshop before 0.7.1 uses HTTP to retrieve packages from the PyPI repository, and does not…
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
pyshop before 0.7.1 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a download operation.
Why it matters now
EPSS 0.02092 81st percentileScored 2026-11-07
Fix Fixed pyshop (PyPI): 0.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pyshop (PyPI) | before 0.7.1 | 0.7.1 | Patch available | GHSA-f594-f3v3-g649 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pyshop (PyPI) Vendor— Affected before 0.7.1 Fixed in 0.7.1 Patch available GHSA-f594-f3v3-g649
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:guillaume_gauvrit:pyshop:*:*:*:*:*:*:*:* | up to 0.7 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.1:*:*:*:*:*:*:* | 0.1 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.2:*:*:*:*:*:*:* | 0.2 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.3:*:*:*:*:*:*:* | 0.3 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.4:*:*:*:*:*:*:* | 0.4 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.5:*:*:*:*:*:*:* | 0.5 | Vulnerable | Guillaume Gauvrit |
| cpe:2.3:a:guillaume_gauvrit:pyshop:0.6:*:*:*:*:*:*:* | 0.6 | Vulnerable | Guillaume Gauvrit |
- cpe:2.3:a:guillaume_gauvrit:pyshop:*:*:*:*:*:*:*:* Versions up to 0.7 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.1:*:*:*:*:*:*:* Versions 0.1 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.2:*:*:*:*:*:*:* Versions 0.2 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.3:*:*:*:*:*:*:* Versions 0.3 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.4:*:*:*:*:*:*:* Versions 0.4 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.5:*:*:*:*:*:*:* Versions 0.5 Vulnerable ·Guillaume Gauvrit
- cpe:2.3:a:guillaume_gauvrit:pyshop:0.6:*:*:*:*:*:*:* Versions 0.6 Vulnerable ·Guillaume Gauvrit
Remediation
- Fix · GHSA-f594-f3v3-g649 pyshop (PyPI) Fixed in 0.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1630
- 2026-10-03 Alias added: GHSA-f594-f3v3-g649
References
Other 6
- https://github.com/mardiros/pyshop/commit/ffadb0bcdef1e385884571670210cfd6ba351784
- https://github.com/mardiros/pyshop/blob/master/CHANGES.txt
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a/
- https://github.com/mardiros/pyshop
- https://github.com/pypa/advisory-database/tree/main/vulns/pyshop/PYSEC-2013-10.yaml
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a
Sources
- CVE-2013-1630 · CVE Program
- CVE-2013-1630 · NVD
- FIRST EPSS
- GHSA-f594-f3v3-g649 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences