easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI…
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-319.
Summary
easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to the default use of the product.
Why it matters now
EPSS 0.0196 80th percentileScored 2026-11-07
Fix Partial setuptools (PyPI): 0.7Red Hat: 5 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | setuptools (PyPI) | before 0.7 | 0.7 | Patch available | GHSA-27x4-j476-jp5f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- setuptools (PyPI) Vendor— Affected before 0.7 Fixed in 0.7 Patch available GHSA-27x4-j476-jp5f
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:setuptools:*:*:*:*:*:*:*:* | up to 0.7b4 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.40:*:*:*:*:*:*:* | 0.6.40 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.41:*:*:*:*:*:*:* | 0.6.41 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.42:*:*:*:*:*:*:* | 0.6.42 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.43:*:*:*:*:*:*:* | 0.6.43 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.44:*:*:*:*:*:*:* | 0.6.44 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.45:*:*:*:*:*:*:* | 0.6.45 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.46:*:*:*:*:*:*:* | 0.6.46 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.47:*:*:*:*:*:*:* | 0.6.47 | Vulnerable | python-pillow |
| cpe:2.3:a:python:setuptools:0.6.48:*:*:*:*:*:*:* | 0.6.48 | Vulnerable | python-pillow |
- cpe:2.3:a:python:setuptools:*:*:*:*:*:*:*:* Versions up to 0.7b4 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.40:*:*:*:*:*:*:* Versions 0.6.40 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.41:*:*:*:*:*:*:* Versions 0.6.41 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.42:*:*:*:*:*:*:* Versions 0.6.42 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.43:*:*:*:*:*:*:* Versions 0.6.43 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.44:*:*:*:*:*:*:* Versions 0.6.44 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.45:*:*:*:*:*:*:* Versions 0.6.45 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.46:*:*:*:*:*:*:* Versions 0.6.46 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.47:*:*:*:*:*:*:* Versions 0.6.47 Vulnerable ·python-pillow
- cpe:2.3:a:python:setuptools:0.6.48:*:*:*:*:*:*:* Versions 0.6.48 Vulnerable ·python-pillow
Show 1 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:setuptools:0.6.49:*:*:*:*:*:*:* | 0.6.49 | Vulnerable | python-pillow |
- cpe:2.3:a:python:setuptools:0.6.49:*:*:*:*:*:*:* Versions 0.6.49 Vulnerable ·python-pillow
Remediation
- Fix · GHSA-27x4-j476-jp5f setuptools (PyPI) Fixed in 0.7 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 5 | Affected | No fix yet |
| Red Hat Enterprise Linux 6 | Affected | No fix yet |
| Red Hat Enterprise MRG 1 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix yet |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1633
- 2026-10-03 Alias added: GHSA-27x4-j476-jp5f
References
Advisory 2
Other 4
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a/
- https://github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2013-22.yaml
- https://github.com/pypa/setuptools
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a
More python-pillow Setuptools vulnerabilities
- TI-2025-29803 setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write CVSS 4.0HIGH 7.7
- TI-2026-42704 setuptools: MANIFEST.in exclusion bypass in sdist via Unicode normalization collision (NFC/NFD) on macOS APFS/HFS+ CVSS 3.1MEDIUM 6.1
- TI-2022-19471 Python Packaging Authority (PyPA) setuptools before 65.5.1 allows remote attackers to… CVSS 3.1MEDIUM 5.9
Sources
- CVE-2013-1633 · CVE Program
- CVE-2013-1633 · NVD
- FIRST EPSS
- GHSA-27x4-j476-jp5f · GitHub Advisory Database · CC BY 4.0
- CVE-2013-1633 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences