Read the docs
TI-2013-01456 Aliases CVE-2013-1655GHSA-574q-fxfj-wv6h

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later…

Priority MEDIUM 40CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Why it matters now

EPSS 0.04558 91st percentileScored 2026-11-07
Fix Fixed puppet (RubyGems): 2.7.21, 3.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—puppet (RubyGems)2.7.0 to before 2.7.212.7.21Patch availableGHSA-574q-fxfj-wv6h
—puppet (RubyGems)3.1.0 to before 3.1.13.1.1Patch availableGHSA-574q-fxfj-wv6h
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • puppet (RubyGems) Vendor— Affected 2.7.0 to before 2.7.21 Fixed in 2.7.21 Patch available GHSA-574q-fxfj-wv6h
  • puppet (RubyGems) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-574q-fxfj-wv6h

CPE configurations NVD · 35

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:*2.7.2VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:*2.7.3VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:*2.7.4VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.5:*:*:*:*:*:*:*2.7.5VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.6:*:*:*:*:*:*:*2.7.6VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.7:*:*:*:*:*:*:*2.7.7VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.8:*:*:*:*:*:*:*2.7.8VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.9:*:*:*:*:*:*:*2.7.9VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.10:*:*:*:*:*:*:*2.7.10VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.11:*:*:*:*:*:*:*2.7.11VulnerablePuppet
  • cpe:2.3:a:puppet:puppet:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.9:*:*:*:*:*:*:* Versions 2.7.9 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.10:*:*:*:*:*:*:* Versions 2.7.10 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.11:*:*:*:*:*:*:* Versions 2.7.11 Vulnerable ·Puppet
Show 25 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet:2.7.12:*:*:*:*:*:*:*2.7.12VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.13:*:*:*:*:*:*:*2.7.13VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.14:*:*:*:*:*:*:*2.7.14VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.16:*:*:*:*:*:*:*2.7.16VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.17:*:*:*:*:*:*:*2.7.17VulnerablePuppet
cpe:2.3:a:puppet:puppet:2.7.18:*:*:*:*:*:*:*2.7.18VulnerablePuppet
cpe:2.3:a:puppet:puppet_enterprise:3.1.0:*:*:*:*:*:*:*3.1.0VulnerablePuppet
cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:*2.7.0VulnerablePuppetlabs
cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:*2.7.1VulnerablePuppetlabs
cpe:2.3:a:puppetlabs:puppet:2.7.19:*:*:*:*:*:*:*2.7.19VulnerablePuppetlabs
cpe:2.3:a:puppetlabs:puppet:2.7.20:*:*:*:*:*:*:*2.7.20VulnerablePuppetlabs
cpe:2.3:a:puppetlabs:puppet:2.7.20:rc1:*:*:*:*:*:*2.7.20 rc1VulnerablePuppetlabs
cpe:2.3:a:ruby-lang:ruby:1.9:*:*:*:*:*:*:*1.9Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.1:*:*:*:*:*:*:*1.9.1Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.2:*:*:*:*:*:*:*1.9.2Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:*:*:*:*:*:*:*1.9.3Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:p0:*:*:*:*:*:*1.9.3 p0Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:p125:*:*:*:*:*:*1.9.3 p125Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:p194:*:*:*:*:*:*1.9.3 p194Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:p286:*:*:*:*:*:*1.9.3 p286Running onruby
cpe:2.3:a:ruby-lang:ruby:1.9.3:p383:*:*:*:*:*:*1.9.3 p383Running onruby
cpe:2.3:a:ruby-lang:ruby:2.0:*:*:*:*:*:*:*2.0Running onruby
cpe:2.3:a:ruby-lang:ruby:2.0.0:*:*:*:*:*:*:*2.0.0Running onruby
cpe:2.3:a:ruby-lang:ruby:2.0.0:rc1:*:*:*:*:*:*2.0.0 rc1Running onruby
cpe:2.3:a:ruby-lang:ruby:2.0.0:rc2:*:*:*:*:*:*2.0.0 rc2Running onruby
  • cpe:2.3:a:puppet:puppet:2.7.12:*:*:*:*:*:*:* Versions 2.7.12 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.13:*:*:*:*:*:*:* Versions 2.7.13 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.14:*:*:*:*:*:*:* Versions 2.7.14 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.16:*:*:*:*:*:*:* Versions 2.7.16 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.17:*:*:*:*:*:*:* Versions 2.7.17 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:2.7.18:*:*:*:*:*:*:* Versions 2.7.18 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_enterprise:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppetlabs:puppet:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Puppetlabs
  • cpe:2.3:a:puppetlabs:puppet:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Puppetlabs
  • cpe:2.3:a:puppetlabs:puppet:2.7.19:*:*:*:*:*:*:* Versions 2.7.19 Vulnerable ·Puppetlabs
  • cpe:2.3:a:puppetlabs:puppet:2.7.20:*:*:*:*:*:*:* Versions 2.7.20 Vulnerable ·Puppetlabs
  • cpe:2.3:a:puppetlabs:puppet:2.7.20:rc1:*:*:*:*:*:* Versions 2.7.20 rc1 Vulnerable ·Puppetlabs
  • cpe:2.3:a:ruby-lang:ruby:1.9:*:*:*:*:*:*:* Versions 1.9 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:p0:*:*:*:*:*:* Versions 1.9.3 p0 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:p125:*:*:*:*:*:* Versions 1.9.3 p125 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:p194:*:*:*:*:*:* Versions 1.9.3 p194 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:p286:*:*:*:*:*:* Versions 1.9.3 p286 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.9.3:p383:*:*:*:*:*:* Versions 1.9.3 p383 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:2.0:*:*:*:*:*:*:* Versions 2.0 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Running on ·ruby
  • cpe:2.3:a:ruby-lang:ruby:2.0.0:rc2:*:*:*:*:*:* Versions 2.0.0 rc2 Running on ·ruby

Remediation

  • Fix · GHSA-574q-fxfj-wv6h puppet (RubyGems) Fixed in 2.7.21 Advisory →
  • Fix · GHSA-574q-fxfj-wv6h puppet (RubyGems) Fixed in 3.1.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-1655
  2. 2026-10-03 Alias added: GHSA-574q-fxfj-wv6h

References

Sources