The crack gem 0.3.1 and earlier for Ruby does not properly restrict casts of string…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264, CWE-704 and the CVSS impact.
Summary
The crack gem 0.3.1 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | crack (RubyGems) | before 0.3.2 | 0.3.2 | Patch available | GHSA-m7fq-cf8q-35q7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- crack (RubyGems) Vendor— Affected before 0.3.2 Fixed in 0.3.2 Patch available GHSA-m7fq-cf8q-35q7
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:john_nunemaker:crack:*:*:*:*:*:*:*:* | up to 0.3.1 | Vulnerable | John Nunemaker |
| cpe:2.3:a:john_nunemaker:crack:0.1.8:*:*:*:*:*:*:* | 0.1.8 | Vulnerable | John Nunemaker |
| cpe:2.3:a:john_nunemaker:crack:0.2.0:*:*:*:*:*:*:* | 0.2.0 | Vulnerable | John Nunemaker |
| cpe:2.3:a:john_nunemaker:crack:0.3.0:*:*:*:*:*:*:* | 0.3.0 | Vulnerable | John Nunemaker |
- cpe:2.3:a:john_nunemaker:crack:*:*:*:*:*:*:*:* Versions up to 0.3.1 Vulnerable ·John Nunemaker
- cpe:2.3:a:john_nunemaker:crack:0.1.8:*:*:*:*:*:*:* Versions 0.1.8 Vulnerable ·John Nunemaker
- cpe:2.3:a:john_nunemaker:crack:0.2.0:*:*:*:*:*:*:* Versions 0.2.0 Vulnerable ·John Nunemaker
- cpe:2.3:a:john_nunemaker:crack:0.3.0:*:*:*:*:*:*:* Versions 0.3.0 Vulnerable ·John Nunemaker
Remediation
- Fix · GHSA-m7fq-cf8q-35q7 crack (RubyGems) Fixed in 0.3.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix yet |
| Red Hat Satellite 6 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1800
- 2026-10-03 Alias added: GHSA-m7fq-cf8q-35q7
References
Other 6
- https://bugzilla.redhat.com/show_bug.cgi?id=917236
- https://bugzilla.novell.com/show_bug.cgi?id=804721
- https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
- https://github.com/jnunemaker/crack
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/crack/CVE-2013-1800.yml
- https://web.archive.org/web/20130203232028/https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
Sources
- CVE-2013-1800 · CVE Program
- CVE-2013-1800 · NVD
- FIRST EPSS
- GHSA-m7fq-cf8q-35q7 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-1800 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences