The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264, CWE-704 and the CVSS impact.
Summary
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | extlib (RubyGems) | before 0.9.16 | 0.9.16 | Patch available | GHSA-9h36-4jf2-hx53 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- extlib (RubyGems) Vendor— Affected before 0.9.16 Fixed in 0.9.16 Patch available GHSA-9h36-4jf2-hx53
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dan_kubb:extlib:*:*:*:*:*:*:*:* | up to 0.9.15 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.2:*:*:*:*:*:*:* | 0.9.2 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.3:*:*:*:*:*:*:* | 0.9.3 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.4:*:*:*:*:*:*:* | 0.9.4 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.5:*:*:*:*:*:*:* | 0.9.5 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.6:*:*:*:*:*:*:* | 0.9.6 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.7:*:*:*:*:*:*:* | 0.9.7 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.8:*:*:*:*:*:*:* | 0.9.8 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.9:*:*:*:*:*:*:* | 0.9.9 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.10:*:*:*:*:*:*:* | 0.9.10 | Vulnerable | Dan Kubb |
- cpe:2.3:a:dan_kubb:extlib:*:*:*:*:*:*:*:* Versions up to 0.9.15 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.2:*:*:*:*:*:*:* Versions 0.9.2 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.3:*:*:*:*:*:*:* Versions 0.9.3 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.4:*:*:*:*:*:*:* Versions 0.9.4 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.5:*:*:*:*:*:*:* Versions 0.9.5 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.6:*:*:*:*:*:*:* Versions 0.9.6 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.7:*:*:*:*:*:*:* Versions 0.9.7 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.8:*:*:*:*:*:*:* Versions 0.9.8 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.9:*:*:*:*:*:*:* Versions 0.9.9 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.10:*:*:*:*:*:*:* Versions 0.9.10 Vulnerable ·Dan Kubb
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dan_kubb:extlib:0.9.11:*:*:*:*:*:*:* | 0.9.11 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.12:*:*:*:*:*:*:* | 0.9.12 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.13:*:*:*:*:*:*:* | 0.9.13 | Vulnerable | Dan Kubb |
| cpe:2.3:a:dan_kubb:extlib:0.9.14:*:*:*:*:*:*:* | 0.9.14 | Vulnerable | Dan Kubb |
- cpe:2.3:a:dan_kubb:extlib:0.9.11:*:*:*:*:*:*:* Versions 0.9.11 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.12:*:*:*:*:*:*:* Versions 0.9.12 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.13:*:*:*:*:*:*:* Versions 0.9.13 Vulnerable ·Dan Kubb
- cpe:2.3:a:dan_kubb:extlib:0.9.14:*:*:*:*:*:*:* Versions 0.9.14 Vulnerable ·Dan Kubb
Remediation
- Fix · GHSA-9h36-4jf2-hx53 extlib (RubyGems) Fixed in 0.9.16 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1802
- 2026-10-03 Alias added: GHSA-9h36-4jf2-hx53
References
Other 5
- https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
- https://bugzilla.redhat.com/show_bug.cgi?id=917233
- https://github.com/datamapper/extlib
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/extlib/CVE-2013-1802.yml
- https://web.archive.org/web/20130203232028/https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
Sources
- CVE-2013-1802 · CVE Program
- CVE-2013-1802 · NVD
- FIRST EPSS
- GHSA-9h36-4jf2-hx53 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-1802 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences