The ruby-openid gem before 2.2.2 for Ruby allows remote OpenID providers to cause a…
Priority LOW 24CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The ruby-openid gem before 2.2.2 for Ruby allows remote OpenID providers to cause a denial of service (CPU consumption) via (1) a large XRDS document or (2) an XML Entity Expansion (XEE) attack.
Why it matters now
EPSS 0.02132 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ruby-openid (RubyGems): 2.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ruby-openid (RubyGems) | before 2.2.2 | 2.2.2 | Patch available | GHSA-6c8p-qphv-668v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ruby-openid (RubyGems) Vendor— Affected before 2.2.2 Fixed in 2.2.2 Patch available GHSA-6c8p-qphv-668v
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* | 17 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* | 18 | Vulnerable | Fedoraproject |
| cpe:2.3:a:janrain:ruby-openid:*:-:-:*:-:ruby:*:* | up to 2.2.1 | Vulnerable | Janrain |
| cpe:2.3:a:janrain:ruby-openid:2.2.0:-:-:*:-:ruby:*:* | 2.2.0 | Vulnerable | Janrain |
- cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* Versions 17 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* Versions 18 Vulnerable ·Fedoraproject
- cpe:2.3:a:janrain:ruby-openid:*:-:-:*:-:ruby:*:* Versions up to 2.2.1 Vulnerable ·Janrain
- cpe:2.3:a:janrain:ruby-openid:2.2.0:-:-:*:-:ruby:*:* Versions 2.2.0 Vulnerable ·Janrain
Remediation
- Fix · GHSA-6c8p-qphv-668v ruby-openid (RubyGems) Fixed in 2.2.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1812
- 2026-10-03 Alias added: GHSA-6c8p-qphv-668v
References
Advisory 4
Sources
- CVE-2013-1812 · CVE Program
- CVE-2013-1812 · NVD
- FIRST EPSS
- GHSA-6c8p-qphv-668v · GitHub Advisory Database · CC BY 4.0
- CVE-2013-1812 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences