Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to…
Priority LOW 21CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application start) or gain privileges by pre-creating a temporary "config" file in a directory with a predictable name in /tmp/ before it is used by the gem.
Why it matters now
EPSS 0.00397 34th percentileScored 2026-11-07
Fix Fixed passenger (RubyGems): 3.0.21, 4.0.5Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | passenger (RubyGems) | before 3.0.21 | 3.0.21 | Patch available | GHSA-9qj7-jvg4-qr2x |
| — | passenger (RubyGems) | 4.0.1 to before 4.0.5 | 4.0.5 | Patch available | GHSA-9qj7-jvg4-qr2x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- passenger (RubyGems) Vendor— Affected before 3.0.21 Fixed in 3.0.21 Patch available GHSA-9qj7-jvg4-qr2x
- passenger (RubyGems) Vendor— Affected 4.0.1 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-9qj7-jvg4-qr2x
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phusion:passenger:*:*:*:*:*:*:*:* | up to 3.0.20 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.3:*:*:*:*:*:*:* | 3.0.3 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.4:*:*:*:*:*:*:* | 3.0.4 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.5:*:*:*:*:*:*:* | 3.0.5 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.6:*:*:*:*:*:*:* | 3.0.6 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.7:*:*:*:*:*:*:* | 3.0.7 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.8:*:*:*:*:*:*:* | 3.0.8 | Vulnerable | Phusion |
- cpe:2.3:a:phusion:passenger:*:*:*:*:*:*:*:* Versions up to 3.0.20 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.3:*:*:*:*:*:*:* Versions 3.0.3 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.4:*:*:*:*:*:*:* Versions 3.0.4 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.5:*:*:*:*:*:*:* Versions 3.0.5 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.6:*:*:*:*:*:*:* Versions 3.0.6 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.7:*:*:*:*:*:*:* Versions 3.0.7 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.8:*:*:*:*:*:*:* Versions 3.0.8 Vulnerable ·Phusion
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phusion:passenger:3.0.9:*:*:*:*:*:*:* | 3.0.9 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.10:*:*:*:*:*:*:* | 3.0.10 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.11:*:*:*:*:*:*:* | 3.0.11 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.12:*:*:*:*:*:*:* | 3.0.12 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.13:*:*:*:*:*:*:* | 3.0.13 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.14:*:*:*:*:*:*:* | 3.0.14 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.15:*:*:*:*:*:*:* | 3.0.15 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.17:*:*:*:*:*:*:* | 3.0.17 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.18:*:*:*:*:*:*:* | 3.0.18 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:3.0.19:*:*:*:*:*:*:* | 3.0.19 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:4.0.3:*:*:*:*:*:*:* | 4.0.3 | Vulnerable | Phusion |
| cpe:2.3:a:phusion:passenger:4.0.4:*:*:*:*:*:*:* | 4.0.4 | Vulnerable | Phusion |
| cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* | all versions | Running on | ruby |
| cpe:2.3:a:redhat:openshift:1.0:*:enterprise:*:*:*:*:* | 1.0 | Vulnerable | Red Hat |
- cpe:2.3:a:phusion:passenger:3.0.9:*:*:*:*:*:*:* Versions 3.0.9 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.10:*:*:*:*:*:*:* Versions 3.0.10 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.11:*:*:*:*:*:*:* Versions 3.0.11 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.12:*:*:*:*:*:*:* Versions 3.0.12 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.13:*:*:*:*:*:*:* Versions 3.0.13 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.14:*:*:*:*:*:*:* Versions 3.0.14 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.15:*:*:*:*:*:*:* Versions 3.0.15 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.17:*:*:*:*:*:*:* Versions 3.0.17 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.18:*:*:*:*:*:*:* Versions 3.0.18 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:3.0.19:*:*:*:*:*:*:* Versions 3.0.19 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·Phusion
- cpe:2.3:a:phusion:passenger:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·Phusion
- cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* Versions all versions Running on ·ruby
- cpe:2.3:a:redhat:openshift:1.0:*:enterprise:*:*:*:*:* Versions 1.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-9qj7-jvg4-qr2x passenger (RubyGems) Fixed in 3.0.21 Advisory →
- Fix · GHSA-9qj7-jvg4-qr2x passenger (RubyGems) Fixed in 4.0.5 Advisory →
Red Hat 1 advisory
- RHSA-2013:1136 Released 2013-08-05 · Red Hat rating Moderaterubygem-passenger security update
- RHOSE Infrastructure 1.2 mod_passenger-3.0.21-3.el6op, ruby193-mod_passenger-3.0.21-3.el6op, ruby193-rubygem-passenger-3.0.21-3.el6op +13
- Red Hat OpenShift Enterprise Node mod_passenger-3.0.21-3.el6op, ruby193-mod_passenger-3.0.21-3.el6op, ruby193-rubygem-passenger-3.0.21-3.el6op +13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| RHOSE Infrastructure 1.2 | Fixed | RHSA-2013:1136 |
| Red Hat OpenShift Enterprise Node | Fixed | RHSA-2013:1136 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2119
- 2026-10-03 Alias added: GHSA-9qj7-jvg4-qr2x
References
Patch 2
Advisory 4
Other 5
- https://access.redhat.com/errata/RHSA-2013:1136
- https://access.redhat.com/security/cve/CVE-2013-2119
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2013-2119.yml
- http://blog.phusion.nl/2013/05/29/phusion-passenger-3-0-21-released
- http://blog.phusion.nl/2013/05/29/phusion-passenger-4-0-5-released
Sources
- CVE-2013-2119 · CVE Program
- CVE-2013-2119 · NVD
- FIRST EPSS
- GHSA-9qj7-jvg4-qr2x · GitHub Advisory Database · CC BY 4.0
- CVE-2013-2119 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences