Read the docs
TI-2013-01901 Aliases CVE-2013-2132GHSA-x33v-f3gp-gw2c

bson/_cbsonmodule.c in the mongo-python-driver (aka.

Priority LOW 27CWE-395Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

bson/_cbsonmodule.c in the mongo-python-driver (aka. pymongo) before 2.5.2, as used in MongoDB, allows context-dependent attackers to cause a denial of service (NULL pointer dereference and crash) via vectors related to decoding of an "invalid DBRef."

Why it matters now

EPSS 0.04108 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pymongo (PyPI): 2.5.2Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—pymongo (PyPI)before 2.5.22.5.2Patch availableGHSA-x33v-f3gp-gw2c
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • pymongo (PyPI) Vendor— Affected before 2.5.2 Fixed in 2.5.2 Patch available GHSA-x33v-f3gp-gw2c

CPE configurations NVD · 18

CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:*up to 2.5.1VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:1.2.0:*:*:*:*:*:*:*1.2.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:1.4.0:*:*:*:*:*:*:*1.4.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:1.6.0:*:*:*:*:*:*:*1.6.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:1.8.0:*:*:*:*:*:*:*1.8.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.0.0:*:*:*:*:*:*:*2.0.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.4.0:*:*:*:*:*:*:*2.4.0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.4.1:*:*:*:*:*:*:*2.4.1VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.4.2:*:*:*:*:*:*:*2.4.2VulnerableMongoDB
  • cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions up to 2.5.1 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:1.4.0:*:*:*:*:*:*:* Versions 1.4.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:1.8.0:*:*:*:*:*:*:* Versions 1.8.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·MongoDB
Show 8 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongodb:2.4.3:*:*:*:*:*:*:*2.4.3VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.4.4:*:*:*:*:*:*:*2.4.4VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.4.5:*:*:*:*:*:*:*2.4.5VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableMongoDB
cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:*12.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:*12.10VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:13.04:*:*:*:*:*:*:*13.04VulnerableCanonical
cpe:2.3:o:opensuse:opensuse:12.3:*:*:*:*:*:*:*12.3VulnerableopenSUSE
  • cpe:2.3:a:mongodb:mongodb:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.4.4:*:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.4.5:*:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·MongoDB
  • cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:* Versions 12.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:* Versions 12.10 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:13.04:*:*:*:*:*:*:* Versions 13.04 Vulnerable ·Canonical
  • cpe:2.3:o:opensuse:opensuse:12.3:*:*:*:*:*:*:* Versions 12.3 Vulnerable ·openSUSE

Remediation

  • Fix · GHSA-x33v-f3gp-gw2c pymongo (PyPI) Fixed in 2.5.2 Advisory →

Red Hat 1 advisory

  • RHSA-2013:1170 Released 2013-08-21 · Red Hat rating Important
    mongodb and pymongo security and enhancement update
    • Red Hat MRG Grid for RHEL 6 Server v.2 mongodb-1.6.4-6.el6, mongodb-server-1.6.4-6.el6, pymongo-1.9-11.el6 +1

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat MRG Grid for RHEL 6 Server v.2Fixed RHSA-2013:1170
Not affected: 1 product
  • Red Hat Satellite 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-2132
  2. 2026-10-03 Alias added: GHSA-x33v-f3gp-gw2c
  3. 2026-10-18 EPSS moved to the 90th–95th percentile

References

Sources