app/models/spree/user.rb in spree_auth_devise in Spree 1.1.x before 1.1.6, 1.2.x, and…
Priority LOW 21CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
app/models/spree/user.rb in spree_auth_devise in Spree 1.1.x before 1.1.6, 1.2.x, and 1.3.x does not perform mass assignment safely when updating a user, which allows remote authenticated users to assign arbitrary roles to themselves.
Why it matters now
EPSS 0.01265 69th percentileScored 2026-11-07
Fix Fixed spree_auth_devise (RubyGems): 3.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | spree_auth_devise (RubyGems) | 1.0.0 to before 3.0.5 | 3.0.5 | Patch available | GHSA-jp57-9j37-5476 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- spree_auth_devise (RubyGems) Vendor— Affected 1.0.0 to before 3.0.5 Fixed in 3.0.5 Patch available GHSA-jp57-9j37-5476
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spreecommerce:spree:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.3:*:*:*:*:*:*:* | 1.1.3 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.4:*:*:*:*:*:*:* | 1.1.4 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.5:*:*:*:*:*:*:* | 1.1.5 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.1.6:*:*:*:*:*:*:* | 1.1.6 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | spree |
- cpe:2.3:a:spreecommerce:spree:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.4:*:*:*:*:*:*:* Versions 1.1.4 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.5:*:*:*:*:*:*:* Versions 1.1.5 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.1.6:*:*:*:*:*:*:* Versions 1.1.6 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·spree
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spreecommerce:spree:1.2.3:*:*:*:*:*:*:* | 1.2.3 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.2.4:*:*:*:*:*:*:* | 1.2.4 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | spree |
| cpe:2.3:a:spreecommerce:spree:1.3.2:*:*:*:*:*:*:* | 1.3.2 | Vulnerable | spree |
- cpe:2.3:a:spreecommerce:spree:1.2.3:*:*:*:*:*:*:* Versions 1.2.3 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.2.4:*:*:*:*:*:*:* Versions 1.2.4 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·spree
- cpe:2.3:a:spreecommerce:spree:1.3.2:*:*:*:*:*:*:* Versions 1.3.2 Vulnerable ·spree
Remediation
- Fix · GHSA-jp57-9j37-5476 spree_auth_devise (RubyGems) Fixed in 3.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2506
- 2026-10-03 Alias added: GHSA-jp57-9j37-5476
References
Advisory 2
Other 7
- https://github.com/spree/spree_auth_devise/commit/038d74771d3b5c13d13b738b73dfda1033a99f65
- https://github.com/spree/spree_auth_devise/commit/fda3ab9fb536c64fe18a9b78bb21c6176b3ea24d
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/spree_auth/CVE-2013-2506.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/spree_auth_devise/CVE-2013-2506.yml
- https://github.com/spree/spree_auth_devise
- https://web.archive.org/web/20131207040639/https://rubygems.org/gems/spree_auth_devise/versions
- https://web.archive.org/web/20160331131233/https://spreecommerce.com/blog/multiple-security-vulnerabilities-fixed
More Spree vulnerabilities
- TI-2011-04629 Spreecommerce < 0.50.x API RCE CVSS 4.0CRITICAL 9.3
- TI-2026-18150 Spree API has Unauthenticated IDOR - Guest Address CVSS 3.1HIGH 7.5
- TI-2026-18149 Spree API has Authenticated Insecure Direct Object Reference (IDOR) via Order Modification CVSS 3.1MEDIUM 6.5
- TI-2011-04622 Spreecommerce < 0.60.2 Search Parameter RCE CVSS 4.0CRITICAL 10.0
- TI-2026-20825 Spree allows unauthenticated users can access all guest addresses CVSS 4.0HIGH 7.7
- TI-2026-20824 Unauthenticated Spree Commerce users can view completed guest orders by Order ID CVSS 4.0HIGH 7.7
Sources
- CVE-2013-2506 · CVE Program
- CVE-2013-2506 · NVD
- FIRST EPSS
- GHSA-jp57-9j37-5476 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences