The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby…
Priority LOW 37CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.
Why it matters now
EPSS 0.02075 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed rgpg (RubyGems): 0.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rgpg (RubyGems) | before 0.2.3 | 0.2.3 | Patch available | GHSA-jg4m-q6w8-vrjp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rgpg (RubyGems) Vendor— Affected before 0.2.3 Fixed in 0.2.3 Patch available GHSA-jg4m-q6w8-vrjp
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:richard_cook:rgpg:*:-:*:*:*:ruby:*:* | up to 0.2.2 | Vulnerable | Richard Cook |
| cpe:2.3:a:richard_cook:rgpg:0.2.0:-:*:*:*:ruby:*:* | 0.2.0 | Vulnerable | Richard Cook |
| cpe:2.3:a:richard_cook:rgpg:0.2.1:-:*:*:*:ruby:*:* | 0.2.1 | Vulnerable | Richard Cook |
- cpe:2.3:a:richard_cook:rgpg:*:-:*:*:*:ruby:*:* Versions up to 0.2.2 Vulnerable ·Richard Cook
- cpe:2.3:a:richard_cook:rgpg:0.2.0:-:*:*:*:ruby:*:* Versions 0.2.0 Vulnerable ·Richard Cook
- cpe:2.3:a:richard_cook:rgpg:0.2.1:-:*:*:*:ruby:*:* Versions 0.2.1 Vulnerable ·Richard Cook
Remediation
- Fix · GHSA-jg4m-q6w8-vrjp rgpg (RubyGems) Fixed in 0.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4203
- 2026-10-03 Alias added: GHSA-jg4m-q6w8-vrjp
References
Sources
- CVE-2013-4203 · CVE Program
- CVE-2013-4203 · NVD
- FIRST EPSS
- GHSA-jg4m-q6w8-vrjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences