Multiple cross-site scripting (XSS) vulnerabilities in the JUnit files in the GWTTestCase…
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the JUnit files in the GWTTestCase in Google Web Toolkit (GWT) before 2.5.1 RC1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01057 64th percentileScored 2026-11-07
Fix Fixed com.google.gwt:gwt (Maven): 2.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.google.gwt:gwt (Maven) | before 2.5.1 | 2.5.1 | Patch available | GHSA-x24q-xwrf-66jm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.google.gwt:gwt (Maven) Vendor— Affected before 2.5.1 Fixed in 2.5.1 Patch available GHSA-x24q-xwrf-66jm
CPE configurations NVD · 30
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:web_toolkit:*:*:*:*:*:*:*:* | up to 2.5.0 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.4.60:*:*:*:*:*:*:* | 1.4.60 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.5.0:rc:*:*:*:*:*:* | 1.5.0 rc | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.5.1:rc2:*:*:*:*:*:* | 1.5.1 rc2 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.5.3:*:*:*:*:*:*:* | 1.5.3 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.6.2:rc:*:*:*:*:*:* | 1.6.2 rc | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.6.3:rc2:*:*:*:*:*:* | 1.6.3 rc2 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.6.4:*:*:*:*:*:*:* | 1.6.4 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:1.7.0:*:*:*:*:*:*:* | 1.7.0 | Vulnerable |
- cpe:2.3:a:google:web_toolkit:*:*:*:*:*:*:*:* Versions up to 2.5.0 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.4.60:*:*:*:*:*:*:* Versions 1.4.60 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.5.0:rc:*:*:*:*:*:* Versions 1.5.0 rc Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.5.1:rc2:*:*:*:*:*:* Versions 1.5.1 rc2 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.5.3:*:*:*:*:*:*:* Versions 1.5.3 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.6.2:rc:*:*:*:*:*:* Versions 1.6.2 rc Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.6.3:rc2:*:*:*:*:*:* Versions 1.6.3 rc2 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.6.4:*:*:*:*:*:*:* Versions 1.6.4 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:1.7.0:*:*:*:*:*:*:* Versions 1.7.0 Vulnerable ·Google
Show 20 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:web_toolkit:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.0:rc1:*:*:*:*:*:* | 2.0.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.1.0:m1:*:*:*:*:*:* | 2.1.0 m1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.1.0:m2:*:*:*:*:*:* | 2.1.0 m2 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.1.0:m3:*:*:*:*:*:* | 2.1.0 m3 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.1.0:rc1:*:*:*:*:*:* | 2.1.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.3.0:m1:*:*:*:*:*:* | 2.3.0 m1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.4:beta:*:*:*:*:*:* | 2.4 beta | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.4.5:*:*:*:*:*:*:* | 2.4.5 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.5.0:rc1:*:*:*:*:*:* | 2.5.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:web_toolkit:2.5.0:rc2:*:*:*:*:*:* | 2.5.0 rc2 | Vulnerable |
- cpe:2.3:a:google:web_toolkit:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.1.0:m1:*:*:*:*:*:* Versions 2.1.0 m1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.1.0:m2:*:*:*:*:*:* Versions 2.1.0 m2 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.1.0:m3:*:*:*:*:*:* Versions 2.1.0 m3 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.1.0:rc1:*:*:*:*:*:* Versions 2.1.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.3.0:m1:*:*:*:*:*:* Versions 2.3.0 m1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.4:beta:*:*:*:*:*:* Versions 2.4 beta Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.4.5:*:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.5.0:rc1:*:*:*:*:*:* Versions 2.5.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:web_toolkit:2.5.0:rc2:*:*:*:*:*:* Versions 2.5.0 rc2 Vulnerable ·Google
Remediation
- Fix · GHSA-x24q-xwrf-66jm com.google.gwt:gwt (Maven) Fixed in 2.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4204
- 2026-10-03 Alias added: GHSA-x24q-xwrf-66jm
References
Patch 2
More Google Web Toolkit vulnerabilities
- TI-2007-02296 The Google Web Toolkit (GWT) framework exchanges data using JavaScript Object Notation… CVSS 2.0MEDIUM 5.0
- TI-2012-04945 Cross-site scripting (XSS) vulnerability in Google Web Toolkit (GWT) 2.4 through 2.5… CVSS 2.0MEDIUM 4.3
- TI-2012-03903 Cross-site scripting (XSS) vulnerability in Google Web Toolkit (GWT) 2.4 Beta and release… CVSS 2.0MEDIUM 4.3
- TI-2007-06149 Unspecified vulnerability in the benchmark reporting system in Google Web Toolkit (GWT)… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2013-4204 · CVE Program
- CVE-2013-4204 · NVD
- FIRST EPSS
- GHSA-x24q-xwrf-66jm · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4204 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences