Read the docs
TI-2013-03720 Aliases CVE-2013-4249GHSA-4894-5vqc-6r2r

Cross-site scripting (XSS) vulnerability in the AdminURLFieldWidget widget in…

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the AdminURLFieldWidget widget in contrib/admin/widgets.py in Django 1.5.x before 1.5.2 and 1.6.x before 1.6 beta 2 allows remote attackers to inject arbitrary web script or HTML via a URLField.

Why it matters now

EPSS 0.02893 86th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed django (PyPI): 1.5.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—django (PyPI)1.5 to before 1.5.21.5.2Patch availableGHSA-4894-5vqc-6r2r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • django (PyPI) Vendor— Affected 1.5 to before 1.5.2 Fixed in 1.5.2 Patch available GHSA-4894-5vqc-6r2r

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:*1.5Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:*1.5 alphaVulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:*1.5 betaVulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:*1.5.1Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:*1.6 beta1Vulnerabledjangoproject
  • cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:* Versions 1.5 alpha Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:* Versions 1.5 beta Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:* Versions 1.6 beta1 Vulnerable ·djangoproject

Remediation

  • Fix · GHSA-4894-5vqc-6r2r django (PyPI) Fixed in 1.5.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-4249
  2. 2026-10-03 Alias added: GHSA-4894-5vqc-6r2r

References

  • TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
  • TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
  • TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
  • TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
  • TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
See all 156 →

Sources