Read the docs
TI-2013-03769 Aliases CVE-2013-4303GHSA-rxq7-cw42-v5ch

Cross-site scripting in Wikimedia Foundation MediaWiki

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

includes/libs/IEUrlExtension.php in the MediaWiki API in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 does not properly detect extensions when there are an even number of "." (period) characters in a string, which allows remote attackers to conduct cross-site scripting (XSS) attacks via the siprop parameter in a query action to wiki/api.php.

Why it matters now

EPSS 0.01527 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed MediaWiki (Wikimedia Foundation): 1.19.8, 1.20.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediaWiki1.19 to before 1.19.8; 1.20 to before 1.20.7; and 1.21.x before 1.21.21.19.8, 1.20.7Patch availableCNA
  • MediaWiki VendorWikimedia Foundation Affected 1.19 to before 1.19.8; 1.20 to before 1.20.7; and 1.21.x before 1.21.2 Fixed in 1.19.8, 1.20.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.19.0 to before 1.19.8; 1.20.0 to before 1.20.7; 1.21.0 to before 1.21.2Vulnerablemediawiki
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.19.0 to before 1.19.8; 1.20.0 to before 1.20.7; 1.21.0 to before 1.21.2 Vulnerable ·mediawiki

Remediation

  • Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.19.8, 1.20.7

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-4303
  2. 2026-10-03 Alias added: GHSA-rxq7-cw42-v5ch

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources