Read the docs
TI-2013-03779 Aliases CVE-2013-4314GHSA-6748-36qp-fx6r

The X509Extension in pyOpenSSL before 0.13.1 does not properly handle a '\0' character in…

Priority LOW 22CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

The X509Extension in pyOpenSSL before 0.13.1 does not properly handle a '\0' character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

Why it matters now

EPSS 0.01197 68th percentileScored 2026-11-07
Fix Fixed pyOpenSSL (PyPI): 0.13.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—pyOpenSSL (PyPI)before 0.13.10.13.1Patch availableGHSA-6748-36qp-fx6r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • pyOpenSSL (PyPI) Vendor— Affected before 0.13.1 Fixed in 0.13.1 Patch available GHSA-6748-36qp-fx6r

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:a:jean-paul_calderone:pyopenssl:*:*:*:*:*:*:*:*up to 0.13VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.7:*:*:*:*:*:*:*0.7VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.8:a1:*:*:*:*:*:*0.8 a1VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.9:*:*:*:*:*:*:*0.9VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.10:*:*:*:*:*:*:*0.10VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:*:*:*:*:*:*:*0.11VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:a1:*:*:*:*:*:*0.11 a1VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:a2:*:*:*:*:*:*0.11 a2VulnerableJean-paul Calderone
cpe:2.3:a:jean-paul_calderone:pyopenssl:0.12:*:*:*:*:*:*:*0.12VulnerableJean-paul Calderone
cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:*10.04VulnerableCanonical
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:*:*:*:*:*:*:*:* Versions up to 0.13 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.7:*:*:*:*:*:*:* Versions 0.7 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.8:a1:*:*:*:*:*:* Versions 0.8 a1 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.9:*:*:*:*:*:*:* Versions 0.9 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.10:*:*:*:*:*:*:* Versions 0.10 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:*:*:*:*:*:*:* Versions 0.11 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:a1:*:*:*:*:*:* Versions 0.11 a1 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.11:a2:*:*:*:*:*:* Versions 0.11 a2 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:a:jean-paul_calderone:pyopenssl:0.12:*:*:*:*:*:*:* Versions 0.12 Vulnerable ·Jean-paul Calderone
  • cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:* Versions 10.04 Vulnerable ·Canonical
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:*12.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:*12.10VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:13.04:*:*:*:*:*:*:*13.04VulnerableCanonical
  • cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:* Versions 12.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:* Versions 12.10 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:13.04:*:*:*:*:*:*:* Versions 13.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-6748-36qp-fx6r pyOpenSSL (PyPI) Fixed in 0.13.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat OpenStack Platform 4
  • Red Hat Storage 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-4314
  2. 2026-10-03 Alias added: GHSA-6748-36qp-fx6r

References

Sources