Directory traversal vulnerability in Django 1.4.x before 1.4.7, 1.5.x before 1.5.3, and…
Priority LOW 29CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in Django 1.4.x before 1.4.7, 1.5.x before 1.5.3, and 1.6.x before 1.6 beta 3 allows remote attackers to read arbitrary files via a file path in the ALLOWED_INCLUDE_ROOTS setting followed by a .. (dot dot) in a ssi template tag.
Why it matters now
EPSS 0.0327 88th percentileScored 2026-11-07
Fix Partial Django (PyPI): 1.4.7, 1.5.3Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.4 to before 1.4.7 | 1.4.7 | Patch available | GHSA-vjjp-9r83-22rc |
| — | Django (PyPI) | 1.5 to before 1.5.3 | 1.5.3 | Patch available | GHSA-vjjp-9r83-22rc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.4 to before 1.4.7 Fixed in 1.4.7 Patch available GHSA-vjjp-9r83-22rc
- Django (PyPI) Vendor— Affected 1.5 to before 1.5.3 Fixed in 1.5.3 Patch available GHSA-vjjp-9r83-22rc
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:* | 1.4.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:* | 1.4.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.4:*:*:*:*:*:*:* | 1.4.4 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.5:*:*:*:*:*:*:* | 1.4.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.4.6:*:*:*:*:*:*:* | 1.4.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:* | 1.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:* | 1.5 alpha | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:* | 1.5 beta | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:* Versions 1.4.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:* Versions 1.4.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.4:*:*:*:*:*:*:* Versions 1.4.4 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.5:*:*:*:*:*:*:* Versions 1.4.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.4.6:*:*:*:*:*:*:* Versions 1.4.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:* Versions 1.5 alpha Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:* Versions 1.5 beta Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·djangoproject
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:* | 1.6 beta1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6:beta2:*:*:*:*:*:* | 1.6 beta2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:* Versions 1.6 beta1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6:beta2:*:*:*:*:*:* Versions 1.6 beta2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-vjjp-9r83-22rc Django (PyPI) Fixed in 1.4.7 Advisory →
- Fix · GHSA-vjjp-9r83-22rc Django (PyPI) Fixed in 1.5.3 Advisory →
Red Hat 1 advisory
- RHSA-2013:1521 Released 2013-11-14 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 3.0 Django14-1.4.8-1.el6ost, Django14-doc-1.4.8-1.el6ost
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 4 | Affected | No fix yet |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 3.0 | Fixed | RHSA-2013:1521 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4315
- 2026-10-03 Alias added: GHSA-vjjp-9r83-22rc
References
Other 5
- https://github.com/django/django/commit/87d2750b39f6f2d54b7047225521a44dcd37e896
- https://github.com/django/django/commit/988b61c550d798f9a66d17ee0511fb7a9a7f33ca
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2013-20.yaml
- https://www.djangoproject.com/weblog/2013/sep/10/security-releases-issued
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-4315 · CVE Program
- CVE-2013-4315 · NVD
- FIRST EPSS
- GHSA-vjjp-9r83-22rc · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4315 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences