Buffer overflow in eglibc
Priority LOW 39CWE-120Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
The eglibc package before 2.14 incorrectly handled the getaddrinfo() function. An attacker could use this issue to cause a denial of service.
Why it matters now
EPSS 0.03225 88th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed eglibc (eglibc): 2.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| eglibc | eglibc | before 2.14 | 2.14 | Patch available | CNA |
- eglibc Vendoreglibc Affected before 2.14 Fixed in 2.14 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eglibc:eglibc:*:*:*:*:*:*:*:* | before 2.14 | Vulnerable | eglibc |
| cpe:2.3:o:novell:suse_linux_enterprise_server:11.0:sp2:*:*:ltss:*:*:* | 11.0 sp2 | Vulnerable | Novell |
| cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:10.04:*:*:*:lts:*:*:* | 10.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* | 18 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* | 19 | Vulnerable | Fedoraproject |
- cpe:2.3:a:eglibc:eglibc:*:*:*:*:*:*:*:* Versions before 2.14 Vulnerable ·eglibc
- cpe:2.3:o:novell:suse_linux_enterprise_server:11.0:sp2:*:*:ltss:*:*:* Versions 11.0 sp2 Vulnerable ·Novell
- cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:10.04:*:*:*:lts:*:*:* Versions 10.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* Versions 18 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* Versions 19 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA eglibc (eglibc) Fixed in 2.14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4357
- 2026-10-03 Alias added: GHSA-66q2-73gm-f5mq
References
Exploit 3
Advisory 9
- https://security-tracker.debian.org/tracker/CVE-2013-4357
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-4357
- https://access.redhat.com/security/cve/cve-2013-4357
- http://www.openwall.com/lists/oss-security/2015/02/24/3
- http://www.openwall.com/lists/oss-security/2013/09/17/4
- http://www.openwall.com/lists/oss-security/2013/09/17/8
- http://www.ubuntu.com/usn/USN-2306-1
- http://www.ubuntu.com/usn/USN-2306-2
- http://www.ubuntu.com/usn/USN-2306-3
Sources
- CVE-2013-4357 · CVE Program
- CVE-2013-4357 · NVD
- FIRST EPSS
- GHSA-66q2-73gm-f5mq · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4357 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences