Directory traversal vulnerability in controller/concerns/render_redirect.rb in the Wicked…
Priority LOW 28CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in controller/concerns/render_redirect.rb in the Wicked gem before 1.0.1 for Ruby allows remote attackers to read arbitrary files via a %2E%2E%2F (encoded dot dot slash) in the step.
Why it matters now
EPSS 0.03015 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed wicked (RubyGems): 1.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | wicked (RubyGems) | before 1.0.1 | 1.0.1 | Patch available | GHSA-rprj-g6xc-p5gq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- wicked (RubyGems) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-rprj-g6xc-p5gq
CPE configurations NVD · 21
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:schneems:wicked:*:*:*:*:*:ruby:*:* | up to 1.0.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.0.1:*:*:*:*:ruby:*:* | 0.0.1 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.0.2:*:*:*:*:ruby:*:* | 0.0.2 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.0:*:*:*:*:ruby:*:* | 0.1.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.1:*:*:*:*:ruby:*:* | 0.1.1 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.2:*:*:*:*:ruby:*:* | 0.1.2 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.3:*:*:*:*:ruby:*:* | 0.1.3 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.4:*:*:*:*:ruby:*:* | 0.1.4 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.5:*:*:*:*:ruby:*:* | 0.1.5 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.1.6:*:*:*:*:ruby:*:* | 0.1.6 | Vulnerable | Schneems |
- cpe:2.3:a:schneems:wicked:*:*:*:*:*:ruby:*:* Versions up to 1.0.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.0.1:*:*:*:*:ruby:*:* Versions 0.0.1 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.0.2:*:*:*:*:ruby:*:* Versions 0.0.2 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.0:*:*:*:*:ruby:*:* Versions 0.1.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.1:*:*:*:*:ruby:*:* Versions 0.1.1 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.2:*:*:*:*:ruby:*:* Versions 0.1.2 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.3:*:*:*:*:ruby:*:* Versions 0.1.3 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.4:*:*:*:*:ruby:*:* Versions 0.1.4 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.5:*:*:*:*:ruby:*:* Versions 0.1.5 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.1.6:*:*:*:*:ruby:*:* Versions 0.1.6 Vulnerable ·Schneems
Show 11 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:schneems:wicked:0.2.0:*:*:*:*:ruby:*:* | 0.2.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.3.0:*:*:*:*:ruby:*:* | 0.3.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.3.1:*:*:*:*:ruby:*:* | 0.3.1 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.3.2:*:*:*:*:ruby:*:* | 0.3.2 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.3.3:*:*:*:*:ruby:*:* | 0.3.3 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.3.4:*:*:*:*:ruby:*:* | 0.3.4 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.4.0:*:*:*:*:ruby:*:* | 0.4.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.5.0:*:*:*:*:ruby:*:* | 0.5.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.6.0:*:*:*:*:ruby:*:* | 0.6.0 | Vulnerable | Schneems |
| cpe:2.3:a:schneems:wicked:0.6.1:*:*:*:*:ruby:*:* | 0.6.1 | Vulnerable | Schneems |
| cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* | all versions | Running on | ruby |
- cpe:2.3:a:schneems:wicked:0.2.0:*:*:*:*:ruby:*:* Versions 0.2.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.3.0:*:*:*:*:ruby:*:* Versions 0.3.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.3.1:*:*:*:*:ruby:*:* Versions 0.3.1 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.3.2:*:*:*:*:ruby:*:* Versions 0.3.2 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.3.3:*:*:*:*:ruby:*:* Versions 0.3.3 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.3.4:*:*:*:*:ruby:*:* Versions 0.3.4 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.4.0:*:*:*:*:ruby:*:* Versions 0.4.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.5.0:*:*:*:*:ruby:*:* Versions 0.5.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.6.0:*:*:*:*:ruby:*:* Versions 0.6.0 Vulnerable ·Schneems
- cpe:2.3:a:schneems:wicked:0.6.1:*:*:*:*:ruby:*:* Versions 0.6.1 Vulnerable ·Schneems
- cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* Versions all versions Running on ·ruby
Remediation
- Fix · GHSA-rprj-g6xc-p5gq wicked (RubyGems) Fixed in 1.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4413
- 2026-10-03 Alias added: GHSA-rprj-g6xc-p5gq
References
Advisory 2
Sources
- CVE-2013-4413 · CVE Program
- CVE-2013-4413 · NVD
- FIRST EPSS
- GHSA-rprj-g6xc-p5gq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences