The Grit gem for Ruby, as used in GitLab 5.2 before 5.4.1 and 6.x before 6.2.3, allows…
Priority LOW 32CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The Grit gem for Ruby, as used in GitLab 5.2 before 5.4.1 and 6.x before 6.2.3, allows remote authenticated users to execute arbitrary commands, as demonstrated by the search box for the GitLab code search feature.
Why it matters now
EPSS 0.01411 72nd percentileScored 2026-11-07
Fix Fixed gitlab-grit (RubyGems): 2.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | gitlab-grit (RubyGems) | before 2.6.1 | 2.6.1 | Patch available | GHSA-95xq-v4m2-fq3r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- gitlab-grit (RubyGems) Vendor— Affected before 2.6.1 Fixed in 2.6.1 Patch available GHSA-95xq-v4m2-fq3r
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:5.4.0:*:*:*:*:*:*:* | 5.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:6.1.0:*:*:*:*:*:*:* | 6.1.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:6.2.0:*:*:*:*:*:*:* | 6.2.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:6.2.1:*:*:*:*:*:*:* | 6.2.1 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:6.2.2:*:*:*:*:*:*:* | 6.2.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:6.1.0:*:*:*:*:*:*:* Versions 6.1.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:6.2.0:*:*:*:*:*:*:* Versions 6.2.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:6.2.1:*:*:*:*:*:*:* Versions 6.2.1 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:6.2.2:*:*:*:*:*:*:* Versions 6.2.2 Vulnerable ·GitLab
Remediation
- Fix · GHSA-95xq-v4m2-fq3r gitlab-grit (RubyGems) Fixed in 2.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4489
- 2026-10-03 Alias added: GHSA-95xq-v4m2-fq3r
References
Other 5
- https://github.com/gitlabhq/grit/commit/40f33a4f4f5604c2a531a1d86901fd81ac4402c4
- https://github.com/gitlabhq/grit
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/gitlab-grit/CVE-2013-4489.yml
- https://gitlab.com/gitlab-org/gitlab-grit/-/blob/v2.6.1/History.txt?ref_type=tags#L2
- https://www.gitlab.com/2013/11/04/gitlab-ce-6-2-and-5-4-security-release
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2013-4489 · CVE Program
- CVE-2013-4489 · NVD
- FIRST EPSS
- GHSA-95xq-v4m2-fq3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences