Cross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 3 fixed, 6 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6 for Ruby allows remote attackers to inject arbitrary web script or HTML via a crafted I18n::MissingTranslationData.new call.
Why it matters now
EPSS 0.02231 82nd percentileScored 2026-11-07
Fix Partial i18n (RubyGems): 0.6.6Red Hat: 2 advisoriesRed Hat: 3 fixed, 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | i18n (RubyGems) | before 0.6.6 | 0.6.6 | Patch available | GHSA-r5hc-9xx5-97rw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- i18n (RubyGems) Vendor— Affected before 0.6.6 Fixed in 0.6.6 Patch available GHSA-r5hc-9xx5-97rw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:i18n_project:i18n:*:*:*:*:*:ruby:*:* | up to 0.6.5 | Vulnerable | I18n Project |
- cpe:2.3:a:i18n_project:i18n:*:*:*:*:*:ruby:*:* Versions up to 0.6.5 Vulnerable ·I18n Project
Remediation
- Fix · GHSA-r5hc-9xx5-97rw i18n (RubyGems) Fixed in 0.6.6 Advisory →
Red Hat 2 advisories
- RHSA-2018:0380 Released 2018-03-01 · Red Hat rating ModerateRed Hat CloudForms security, bug fix, and enhancement update
- CloudForms Management Engine 5.9 ansible-2.4.3.0-1.el7ae, ansible-doc-2.4.3.0-1.el7ae, ansible-tower-3.1.5-3.el7at +47
- RHSA-2017:0320 Released 2017-02-27 · Red Hat rating ModerateCFME 5.7.1 bug fixes and enhancement update
- CloudForms Management Engine 5.7 cfme-5.7.1.3-1.el7cf, cfme-appliance-5.7.1.3-1.el7cf, cfme-gemset-5.7.1.3-1.el7cf
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| CloudForms Management Engine 5.4 | Fixed | — |
| CloudForms Management Engine 5.7 | Fixed | RHSA-2017:0320 |
| CloudForms Management Engine 5.9 | Fixed | RHSA-2018:0380 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4492
- 2026-10-03 Alias added: GHSA-r5hc-9xx5-97rw
References
Advisory 4
Other 14
- [ruby-security-ann] 20131203 [CVE-2013-4491] Reflective XSS Vulnerability in Ruby on Rails
- https://github.com/svenfuchs/i18n/commit/92b57b1e4f84adcdcc3a375278f299274be62445
- https://github.com/ruby-i18n/i18n/commit/92b57b1e4f84adcdcc3a375278f299274be62445
- https://access.redhat.com/errata/RHBA-2015:1100
- https://access.redhat.com/errata/RHSA-2017:0320
- https://access.redhat.com/errata/RHSA-2018:0380
- https://access.redhat.com/security/cve/CVE-2013-4492
- https://bugzilla.redhat.com/show_bug.cgi?id=1039435
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/i18n/CVE-2013-4492.yml
- https://github.com/svenfuchs/i18n
- https://groups.google.com/forum/#!topic/ruby-security-ann/pLrh6DUw998
- https://web.archive.org/web/20201208125214/https://groups.google.com/forum/message/raw?msg=ruby-security-ann/pLrh6DUw998/bLFEyIO4k_EJ
- https://web.archive.org/web/20210731082547/http://www.securityfocus.com/bid/64076
- http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released
More I18n Project I18n vulnerabilities
- TI-2014-08233 Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows… CVSS 3.0HIGH 7.5
- TI-2020-06307 Denial of service (DoS) in i18n CVSS 3.1HIGH 7.5
Sources
- CVE-2013-4492 · CVE Program
- CVE-2013-4492 · NVD
- FIRST EPSS
- GHSA-r5hc-9xx5-97rw · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4492 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences