Improper privilege management in GitLab
Priority MEDIUM 42CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
The parse_cmd function in lib/gitlab_shell.rb in GitLab 5.0 before 5.4.2, Community Edition before 6.2.4, and Enterprise Edition before 6.2.1 and gitlab-shell before 1.7.8 allows remote authenticated users to gain privileges and clone arbitrary repositories.
Why it matters now
EPSS 0.02 80th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 5.4.2GitLab Community Edition (GitLab): 6.2.4+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 5.0 to before 5.4.2 | 5.4.2 | Patch available | CNA |
| GitLab | GitLab Community Edition | before 6.2.4 | 6.2.4 | Patch available | CNA |
| GitLab | GitLab Enterprise Edition | before 6.2.1 | 6.2.1 | Patch available | CNA |
| GitLab | gitlab-shell | before 1.7.8 | 1.7.8 | Patch available | CNA |
- GitLab VendorGitLab Affected 5.0 to before 5.4.2 Fixed in 5.4.2 Patch available CNA
- GitLab Community Edition VendorGitLab Affected before 6.2.4 Fixed in 6.2.4 Patch available CNA
- GitLab Enterprise Edition VendorGitLab Affected before 6.2.1 Fixed in 6.2.1 Patch available CNA
- gitlab-shell VendorGitLab Affected before 1.7.8 Fixed in 1.7.8 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:* | 5.0.0 to before 5.4.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 6.0.0 to before 6.2.1 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 6.0.0 to before 6.2.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab-shell:*:*:*:*:*:*:*:* | before 1.7.8 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.4.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 6.0.0 to before 6.2.1 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 6.0.0 to before 6.2.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab-shell:*:*:*:*:*:*:*:* Versions before 1.7.8 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 5.4.2
- Fix · CNA GitLab Community Edition (GitLab) Fixed in 6.2.4
- Fix · CNA GitLab Enterprise Edition (GitLab) Fixed in 6.2.1
- Fix · CNA gitlab-shell (GitLab) Fixed in 1.7.8
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4583
- 2026-10-03 Alias added: GHSA-r692-jg36-6v4p
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2013-4583 · CVE Program
- CVE-2013-4583 · NVD
- FIRST EPSS
- GHSA-r692-jg36-6v4p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences