Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to…
Priority LOW 38CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Why it matters now
EPSS 0.02997 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed openid/php-openid (Packagist): 2.3.0typo3/cms (Packagist): 6.2.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | openid/php-openid (Packagist) | before 2.3.0 | 2.3.0 | Patch available | GHSA-5qp6-78pr-gv8c |
| — | typo3/cms (Packagist) | 6.2.0 to before 6.2.6 | 6.2.6 | Patch available | GHSA-5qp6-78pr-gv8c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- openid/php-openid (Packagist) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-5qp6-78pr-gv8c
- typo3/cms (Packagist) Vendor— Affected 6.2.0 to before 6.2.6 Fixed in 6.2.6 Patch available GHSA-5qp6-78pr-gv8c
Remediation
- Fix · GHSA-5qp6-78pr-gv8c openid/php-openid (Packagist) Fixed in 2.3.0 Advisory →
- Fix · GHSA-5qp6-78pr-gv8c typo3/cms (Packagist) Fixed in 6.2.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4701
- 2026-10-03 Alias added: GHSA-5qp6-78pr-gv8c
References
Advisory 5
More Janrain Php-openid vulnerabilities
- TI-2016-01880 examples/consumer/common.php in JanRain PHP OpenID library (aka php-openid) improperly… CVSS 3.0HIGH 8.8
- TI-2011-03264 JanRain PHP OpenID library (aka php-openid) 2.2.2 allows remote attackers to obtain… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2013-4701 · CVE Program
- CVE-2013-4701 · NVD
- FIRST EPSS
- GHSA-5qp6-78pr-gv8c · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4701 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences