php-symfony2-Validator has loss of information during serialization
Priority LOW 38CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
php-symfony2-Validator has loss of information during serialization
Why it matters now
EPSS 0.01445 73rd percentileScored 2026-11-07
Fix Fixed symfony/validator (Packagist): 2.0.24, 2.1.12, 2.2.5 +1symfony/symfony (Packagist): 2.0.24, 2.1.12, 2.2.5 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/validator (Packagist) | 2.0.0 to before 2.0.24 | 2.0.24 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/validator (Packagist) | 2.1.0 to before 2.1.12 | 2.1.12 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/validator (Packagist) | 2.2.0 to before 2.2.5 | 2.2.5 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/validator (Packagist) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/symfony (Packagist) | 2.0.0 to before 2.0.24 | 2.0.24 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/symfony (Packagist) | 2.1.0 to before 2.1.12 | 2.1.12 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/symfony (Packagist) | 2.2.0 to before 2.2.5 | 2.2.5 | Patch available | GHSA-q8j7-fjh7-25v5 |
| — | symfony/symfony (Packagist) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-q8j7-fjh7-25v5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/validator (Packagist) Vendor— Affected 2.0.0 to before 2.0.24 Fixed in 2.0.24 Patch available GHSA-q8j7-fjh7-25v5
- symfony/validator (Packagist) Vendor— Affected 2.1.0 to before 2.1.12 Fixed in 2.1.12 Patch available GHSA-q8j7-fjh7-25v5
- symfony/validator (Packagist) Vendor— Affected 2.2.0 to before 2.2.5 Fixed in 2.2.5 Patch available GHSA-q8j7-fjh7-25v5
- symfony/validator (Packagist) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-q8j7-fjh7-25v5
- symfony/symfony (Packagist) Vendor— Affected 2.0.0 to before 2.0.24 Fixed in 2.0.24 Patch available GHSA-q8j7-fjh7-25v5
- symfony/symfony (Packagist) Vendor— Affected 2.1.0 to before 2.1.12 Fixed in 2.1.12 Patch available GHSA-q8j7-fjh7-25v5
- symfony/symfony (Packagist) Vendor— Affected 2.2.0 to before 2.2.5 Fixed in 2.2.5 Patch available GHSA-q8j7-fjh7-25v5
- symfony/symfony (Packagist) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-q8j7-fjh7-25v5
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.0.0 to before 2.0.24; 2.1.0 to before 2.1.12; 2.2.0 to before 2.2.5; 2.3.0 to before 2.3.3 | Vulnerable | sensiolabs |
| cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* | 18 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* | 19 | Vulnerable | Fedoraproject |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.24; 2.1.0 to before 2.1.12; 2.2.0 to before 2.2.5; 2.3.0 to before 2.3.3 Vulnerable ·sensiolabs
- cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:* Versions 18 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* Versions 19 Vulnerable ·Fedoraproject
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-q8j7-fjh7-25v5 symfony/validator (Packagist) Fixed in 2.0.24 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/validator (Packagist) Fixed in 2.1.12 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/validator (Packagist) Fixed in 2.2.5 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/validator (Packagist) Fixed in 2.3.3 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/symfony (Packagist) Fixed in 2.0.24 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/symfony (Packagist) Fixed in 2.1.12 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/symfony (Packagist) Fixed in 2.2.5 Advisory →
- Fix · GHSA-q8j7-fjh7-25v5 symfony/symfony (Packagist) Fixed in 2.3.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4751
- 2026-10-03 Alias added: GHSA-q8j7-fjh7-25v5
References
Advisory 4
Other 5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2013-4751.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/validator/CVE-2013-4751.yaml
- https://github.com/symfony/validator
- https://symfony.com/blog/security-releases-symfony-2-0-24-2-1-12-2-2-5-and-2-3-3-released
- https://web.archive.org/web/20200228181137/http://www.securityfocus.com/bid/61709
Sources
- CVE-2013-4751 · CVE Program
- CVE-2013-4751 · NVD
- FIRST EPSS
- GHSA-q8j7-fjh7-25v5 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4751 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences