The authenticated-encryption feature in the symmetric-encryption implementation in the…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The authenticated-encryption feature in the symmetric-encryption implementation in the OWASP Enterprise Security API (ESAPI) for Java 2.x before 2.1.0 does not properly resist tampering with serialized ciphertext, which makes it easier for remote attackers to bypass intended cryptographic protection mechanisms via an attack against authenticity in the default configuration, involving a null MAC and a zero MAC length.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.owasp.esapi:esapi (Maven) | 2.0.0 to before 2.1.0 | 2.1.0 | Patch available | GHSA-jcp9-796g-pv9p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.owasp.esapi:esapi (Maven) Vendor— Affected 2.0.0 to before 2.1.0 Fixed in 2.1.0 Patch available GHSA-jcp9-796g-pv9p
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owasp:enterprise_security_api:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | owasp-modsecurity |
| cpe:2.3:a:owasp:enterprise_security_api:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | owasp-modsecurity |
- cpe:2.3:a:owasp:enterprise_security_api:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·owasp-modsecurity
- cpe:2.3:a:owasp:enterprise_security_api:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·owasp-modsecurity
Remediation
- Fix · GHSA-jcp9-796g-pv9p org.owasp.esapi:esapi (Maven) Fixed in 2.1.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-5679
- 2026-10-03 Alias added: GHSA-jcp9-796g-pv9p
References
More owasp-modsecurity Enterprise Security Api vulnerabilities
- TI-2022-07517 Path Traversal in ESAPI CVSS 3.1CRITICAL 9.8
- TI-2022-08701 Cross-site Scripting in org.owasp.esapi:esapi -- antisamy-esapi.xml configuration file CVSS 3.1MEDIUM 6.1
- TI-2013-05080 The authenticated-encryption feature in the symmetric-encryption implementation in the… CVSS 2.0MEDIUM 5.8
Sources
- CVE-2013-5679 · CVE Program
- CVE-2013-5679 · NVD
- FIRST EPSS
- GHSA-jcp9-796g-pv9p · GitHub Advisory Database · CC BY 4.0
- CVE-2013-5679 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences