Cross-site scripting (XSS) vulnerability in the Apache Solr for TYPO3 (solr) extension…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01808 78th percentileScored 2026-11-07
Fix Fixed apache-solr-for-typo3/solr (Packagist): 2.8.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | apache-solr-for-typo3/solr (Packagist) | before 2.8.3 | 2.8.3 | Patch available | GHSA-xc7q-q62f-wcvr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- apache-solr-for-typo3/solr (Packagist) Vendor— Affected before 2.8.3 Fixed in 2.8.3 Patch available GHSA-xc7q-q62f-wcvr
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ingo_renner:apache_solr:*:*:*:*:*:*:*:* | up to 2.8.2 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Ingo Renner |
| cpe:2.3:a:ingo_renner:apache_solr:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Ingo Renner |
- cpe:2.3:a:ingo_renner:apache_solr:*:*:*:*:*:*:*:* Versions up to 2.8.2 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Ingo Renner
- cpe:2.3:a:ingo_renner:apache_solr:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Ingo Renner
Remediation
- Fix · GHSA-xc7q-q62f-wcvr apache-solr-for-typo3/solr (Packagist) Fixed in 2.8.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6289
- 2026-10-03 Alias added: GHSA-xc7q-q62f-wcvr
References
Other 5
- http://typo3.org/teams/security/security-bulletins/typo3-extensions/typo3-ext-sa-2013-009/
- https://github.com/TYPO3-Solr/ext-solr/commit/57e3b06b498668e093b9b86f32f7509d12d6ae4e
- https://github.com/TYPO3-Solr/ext-solr/commit/7ed1e9fc03f2036d80a416178493da72c620f7e9
- https://github.com/TYPO3-Solr/ext-solr
- http://typo3.org/teams/security/security-bulletins/typo3-extensions/typo3-ext-sa-2013-009
More Ingo Renner Apache Solr vulnerabilities
- TI-2013-05268 Unspecified vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for… CVSS 2.0HIGH 10.0
Sources
- CVE-2013-6289 · CVE Program
- CVE-2013-6289 · NVD
- FIRST EPSS
- GHSA-xc7q-q62f-wcvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences